summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm103
1 files changed, 77 insertions, 26 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eb15cbc428..5a681d9c64 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,14 +11,14 @@
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016, 2018 Rene Saavedra <pacoon@protonmail.com>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
-;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
@@ -32,6 +32,7 @@
;;; Copyright © 2018 Manuel Graf <graf@init.at>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,8 +406,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
It has been modified to remove all non-free binary blobs.")
(license license:gpl2)))
-(define %linux-libre-version "5.0.1")
-(define %linux-libre-hash "0izbdpml170g5jg87ccnf2q1hc01gsyiy1gqxnqzzi3pri00dfyz")
+(define %linux-libre-version "5.0.3")
+(define %linux-libre-hash "1ivdqr3y8r2hmv3a1g0a641cr2ckl3x4arapw0j6nwd0sbcyncam")
(define %linux-libre-5.0-patches
(list %boot-logo-patch
@@ -419,8 +420,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-5.0-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.19-version "4.19.28")
-(define %linux-libre-4.19-hash "0j65gp9z3qrygx67mkhm4ri3pj1pz0gdwcdlds2ypg53rh12jc0a")
+(define %linux-libre-4.19-version "4.19.30")
+(define %linux-libre-4.19-hash "1i15cs7zb53hagllgga8jaz0j1p9b22j93iczwc2w587zzhzlvng")
(define %linux-libre-4.19-patches
(list %boot-logo-patch
@@ -433,8 +434,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-4.19-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.105")
-(define %linux-libre-4.14-hash "06pp13d2g0j2v8jy8fh20b4ismzg9wn3i7bnx2hpyvslz256rrgg")
+(define %linux-libre-4.14-version "4.14.107")
+(define %linux-libre-4.14-hash "19i17b8sjjvi99vya1vncjalysdy027hp35rrla68gjs28dyas7r")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -443,8 +444,8 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.162"
- "07swv6xvjsl5nv5y3sc2nfdnmqdz9gjy8hgrjvi0bljwzf1fbxmy"
+ (make-linux-libre "4.9.164"
+ "06bbynvijqlk92bpppmnjijyfwr0sk01krqdw4hpgbrvlg3wdlbk"
'("x86_64-linux" "i686-linux")
#:configuration-file kernel-config))
@@ -963,7 +964,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(define-public strace
(package
(name "strace")
- (version "4.26")
+ (version "5.0")
(home-page "https://strace.io")
(source (origin
(method url-fetch)
@@ -971,7 +972,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
"/strace-" version ".tar.xz"))
(sha256
(base32
- "070yz8xii8gnb4psiz628zwm5srh266sfb06f7f1qzagxzz2ykbw"))))
+ "1nj7wvsdmhpp53yffj1pnrkjn96mxrbcraa6h03wc7dqn9zdfyiv"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1251,7 +1252,7 @@ that the Ethernet protocol is much simpler than the IP protocol.")
(define-public iproute
(package
(name "iproute2")
- (version "4.20.0")
+ (version "5.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1259,10 +1260,11 @@ that the Ethernet protocol is much simpler than the IP protocol.")
version ".tar.xz"))
(sha256
(base32
- "1a7xyvqjxfnm7rk21amm0xgxa38clg7q7cmc4dmlg27q81mambf8"))))
+ "1fi03lb8dqr8hq633gcqsf6228vsvysxms075j1yyl4nlc17616z"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
+ `( ;; There is a test suite, but it wants network namespaces and sudo.
+ #:tests? #f
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "DESTDIR="
(string-append "BASH_COMPDIR=" out
@@ -1282,12 +1284,15 @@ that the Ethernet protocol is much simpler than the IP protocol.")
(("^.*ARPDDIR.*$") ""))
#t)))))
(inputs
- `(("iptables" ,iptables)
- ("db4" ,bdb)))
+ `(("db4" ,bdb)
+ ("iptables" ,iptables)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("bison" ,bison)
("flex" ,flex)
- ("bison" ,bison)))
+ ("pkg-config" ,pkg-config)))
+ ;; For tests.
+ ;; ("libmnl" ,libmnl)
+ ;; ("util-linux" ,util-linux)
(home-page
"https://wiki.linuxfoundation.org/networking/iproute2")
(synopsis
@@ -4052,7 +4057,7 @@ of flash storage.")
(define-public libseccomp
(package
(name "libseccomp")
- (version "2.3.3")
+ (version "2.4.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/seccomp/libseccomp/"
@@ -4060,7 +4065,7 @@ of flash storage.")
"/libseccomp-" version ".tar.gz"))
(sha256
(base32
- "0mdiyfljrkfl50q1m3ws8yfcyfjwf1zgkvcva8ffcwncji18zhkz"))))
+ "0paj1szszpf8plykrd66jqg1x3kmqs395rbjskahld2bnplcfx1f"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)))
@@ -4275,7 +4280,7 @@ Light is the successor of lightscript.")
(define-public tlp
(package
(name "tlp")
- (version "1.1")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4285,7 +4290,7 @@ Light is the successor of lightscript.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "068hzmh90x600saynbl7iwg1pm0ywldn4jazyxx5y1fixs8s1qbn"))))
+ "0rcp9i0fisdm4h6799ffr696l1vl661fnwb2dij268nlwwmkr90g"))))
(inputs `(("bash" ,bash)
("dbus" ,dbus)
("ethtool" ,ethtool)
@@ -4315,7 +4320,8 @@ Light is the successor of lightscript.")
(setenv "TLP_NO_PMUTILS" "1")
(setenv "TLP_SBIN" (string-append out "/bin"))
(setenv "TLP_BIN" (string-append out "/bin"))
- (setenv "TLP_TLIB" (string-append out "/share/tlp-pm"))
+ (setenv "TLP_TLIB" (string-append out "/share/tlp"))
+ (setenv "TLP_FLIB" (string-append out "/share/tlp/func.d"))
(setenv "TLP_ULIB" (string-append out "/lib/udev"))
(setenv "TLP_CONF" "/etc/tlp")
(setenv "TLP_SHCPL"
@@ -4369,7 +4375,6 @@ Light is the successor of lightscript.")
a default configuration already optimized for battery life. Nevertheless,
TLP is customizable to fulfil system requirements. TLP settings are applied
every time the power supply source is changed.")
-
;; 'COPYING' is a custom version that says that one file is GPLv3+ and the
;; rest is GPLv2+.
(license (list license:gpl2+ license:gpl3+))))
@@ -5076,7 +5081,11 @@ management tools in userspace.")
"0ss0r6jlxxinf9fhpc0fgf7b89n9mzirpa85xxjmi1ix9l6cls6x"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f)) ; kernel/user integration tests are in package "xfstests"
+ `(#:tests? #f ;kernel/user integration tests are in package "xfstests"
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-headers
+ (lambda _
+ (invoke "make" "install-dev"))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("util-linux" ,util-linux)))
@@ -5194,3 +5203,45 @@ the correct permissions and ownership, and then pack them up, or one would
have to construct the archives directly, without using the archiver.")
(home-page "http://freshmeat.sourceforge.net/projects/fakeroot")
(license license:gpl3+)))
+
+(define-public inputattach
+ (package
+ (name "inputattach")
+ (version "0.42.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxwacom/input-wacom.git")
+ (commit (string-append "input-wacom-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04lnn7v0rm4ppbya140im5d4igcl6c1nrqpgbsr0i8wkral0nv7j"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "inputattach"
+ (invoke (string-append (assoc-ref inputs "gcc")
+ "/bin/gcc")
+ "-O2" "-o" "inputattach" "inputattach.c"))
+ #t))
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((target-dir (string-append
+ (assoc-ref outputs "out")
+ "/bin/")))
+ (mkdir-p target-dir)
+ (copy-file "inputattach/inputattach"
+ (string-append target-dir
+ "inputattach"))
+ #t))))))
+ (home-page "https://linuxwacom.github.io/")
+ (synopsis "Dispatch input peripherals events to a device file")
+ (description "inputattach dispatches input events from several device
+types and interfaces and translates so that the X server can use them.")
+ (license license:gpl2+)))