summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm324
1 files changed, 142 insertions, 182 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d19d6b754f..aa777095c4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -640,11 +640,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The following package is used in the early bootstrap, and thus must be kept
;; stable and with minimal build requirements.
-(define-public linux-libre-headers-5.10.35
- (make-linux-libre-headers "5.10.35" "gnu"
- "0q2rnchad55d49f3rajrkazz0fcjv1irwrdb1hwjnl01fzm2gjk3"))
+(define-public linux-libre-headers-5.15.49
+ (make-linux-libre-headers "5.15.49" "gnu"
+ "13zqdcm4664vh7g57sxbfrlpsxm7zrma72mxdfdz7d9yndy2gfv8"))
-(define-public linux-libre-headers linux-libre-headers-5.10.35)
+(define-public linux-libre-headers linux-libre-headers-5.15.49)
;;;
@@ -1550,7 +1550,8 @@ which need to be installed separately.")
(sha256
(base32
"1z4jayf69qyyxln1gl6ch4qxfd66ib1g42garnrv2d8i1drl0790"))
- (patches (search-patches "linux-pam-no-setfsuid.patch"))))
+ (patches (search-patches "linux-pam-unix_chkpwd.patch"
+ "linux-pam-no-setfsuid.patch"))))
(build-system gnu-build-system)
(native-inputs
@@ -1760,8 +1761,7 @@ providing the system administrator with some help in common tasks.")
(define-public util-linux
(package
(name "util-linux")
- (replacement util-linux/fixed)
- (version "2.37.2")
+ (version "2.37.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/"
@@ -1769,7 +1769,7 @@ providing the system administrator with some help in common tasks.")
"util-linux-" version ".tar.xz"))
(sha256
(base32
- "1ng9517c37mdp858425a4zyybma7dh7jrpd6z1z61yz7mb0n81va"))
+ "10svcnsqmrsd660bzcm7k6dm8sa7hkknhr3bag1nccwimlb6jkk3"))
(patches (search-patches "util-linux-tests.patch"))
(modules '((guix build utils)))
(snippet
@@ -1786,102 +1786,101 @@ providing the system administrator with some help in common tasks.")
"lib" ;8.8 MiB shared libraries, headers and locales
"static")) ;2.9 MiB static .a libraries
(arguments
- `(#:configure-flags (list "--disable-use-tty-group"
- (string-append
- "--enable-fs-paths-default="
- "/run/setuid-programs"
- ":/run/current-system/profile/sbin")
- ;; Don't try to chown root:root mount and umount
- "--disable-makeinstall-chown"
- "--localstatedir=/var"
- (string-append "--localedir="
- (assoc-ref %outputs "lib")
- "/share/locale")
- ;; Install completions where our
- ;; bash-completion package expects them.
- (string-append "--with-bashcompletiondir="
- (assoc-ref %outputs "out")
- "/etc/bash_completion.d"))
-
- ;; FIXME: For now we cannot reliably run tests on GNU/Hurd:
- ;; <https://bugs.gnu.org/47791>.
- #:tests? ,(and (not (%current-target-system))
- (not (string-suffix? "-gnu" (%current-system))))
+ (list #:configure-flags
+ #~(list "--disable-use-tty-group"
+ (string-append
+ "--enable-fs-paths-default="
+ "/run/setuid-programs"
+ ":/run/current-system/profile/sbin")
+ ;; Don't try to chown root:root mount and umount
+ "--disable-makeinstall-chown"
+ "--localstatedir=/var"
+ (string-append "--localedir=" #$output:lib
+ "/share/locale")
+ ;; Install completions where our bash-completion package
+ ;; expects them.
+ (string-append "--with-bashcompletiondir=" #$output
+ "/etc/bash_completion.d"))
+
+ ;; FIXME: For now we cannot reliably run tests on GNU/Hurd:
+ ;; <https://bugs.gnu.org/47791>.
+ #:tests? (and (not (%current-target-system))
+ (not (string-suffix? "-gnu" (%current-system))))
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'patch-build-scripts
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "configure"
- ;; The build system assumes that we want to install
- ;; libraries below $exec_prefix when $libdir does not
- ;; match any of the "usual" locations. Fix that.
- (("usrlib_execdir='\\$\\{exec_prefix\\}'\\$libdir")
- "usrlib_execdir=$libdir"))))
- (add-before 'build 'set-umount-file-name
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Tell 'eject' the right file name of 'umount'.
- (let ((out (assoc-ref outputs "out")))
- (substitute* "sys-utils/eject.c"
- (("\"/bin/umount\"")
- (string-append "\"" out "/bin/umount\""))))))
- (add-before 'check 'pre-check
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (let ((services (search-input-file (or native-inputs inputs)
- "etc/services")))
- ;; Change the test to refer to the right file.
- (substitute* "tests/ts/misc/mcookie"
- (("/etc/services")
- services))
-
- ;; The C.UTF-8 locale does not exist in our libc.
- (substitute* "tests/ts/column/invalid-multibyte"
- (("C\\.UTF-8") "en_US.utf8")))))
- (add-before 'check 'disable-setarch-test
- (lambda _
- ;; The setarch tests are unreliable in QEMU's user-mode
- ;; emulation, which is our primary method of building
- ;; ARMv7 packages. See
- ;; <https://github.com/karelzak/util-linux/issues/601>.
- (substitute* "tests/ts/misc/setarch"
- (("ts_init_subtest.*" all)
- (string-append
- all "\n"
- "ts_skip \"setarch tests are unreliable under QEMU\"")))))
- (add-before 'check 'disable-lsns-test
- (lambda _
- ;; The lsns tests can fail due to ioctl(_, NS_GET_USERNS)
- ;; returning ENOTTY, indicating this kernel does not
- ;; support user namespaces. Curiously, this test can fail
- ;; on i686 even if the same test passes on x86_64 on the
- ;; same machine. See <https://issues.guix.gnu.org/49933>.
- (delete-file "tests/ts/lsns/ioctl_ns")))
- (add-after 'install 'move-static-libraries
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((lib (assoc-ref outputs "lib"))
- (static (assoc-ref outputs "static")))
-
- ;; Move static libraries to the "static" output.
- (mkdir-p (string-append static "/lib"))
- (with-directory-excursion lib
- (for-each (lambda (file)
- (rename-file file
- (string-append static "/"
- file)))
- (find-files "lib" "\\.a$"))
-
- ;; Remove references to the static library from the '.la'
- ;; files so that Libtool does the right thing when both
- ;; the shared and static library is available.
- (substitute* (find-files "lib" "\\.la$")
- (("old_library=.*") "old_library=''\n"))))))
- (add-after 'install 'adjust-pkg-config-files
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((lib (assoc-ref outputs "lib")))
- ;; Drop the unused "prefix=" and "exec_prefix=" variables from
- ;; the pkg-config files to avoid a cyclic reference on "out".
- (substitute* (find-files (string-append lib "/lib/pkgconfig")
- "\\.pc$")
- (("^(exec_)?prefix=.*") ""))))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-build-scripts
+ (lambda _
+ (substitute* "configure"
+ ;; The build system assumes that we want to install
+ ;; libraries below $exec_prefix when $libdir does not
+ ;; match any of the "usual" locations. Fix that.
+ (("usrlib_execdir='\\$\\{exec_prefix\\}'\\$libdir")
+ "usrlib_execdir=$libdir"))))
+ (add-before 'build 'set-umount-file-name
+ (lambda _
+ ;; Tell 'eject' the right file name of 'umount'.
+ (substitute* "sys-utils/eject.c"
+ (("\"/bin/umount\"")
+ (string-append "\"" #$output "/bin/umount\"")))))
+ (add-before 'check 'pre-check
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (let ((services (search-input-file (or native-inputs inputs)
+ "etc/services")))
+ ;; Change the test to refer to the right file.
+ (substitute* "tests/ts/misc/mcookie"
+ (("/etc/services")
+ services))
+
+ ;; The C.UTF-8 locale does not exist in our libc.
+ (substitute* "tests/ts/column/invalid-multibyte"
+ (("C\\.UTF-8") "en_US.utf8")))))
+ (add-before 'check 'disable-setarch-test
+ (lambda _
+ ;; The setarch tests are unreliable in QEMU's user-mode
+ ;; emulation, which is our primary method of building
+ ;; ARMv7 packages. See
+ ;; <https://github.com/karelzak/util-linux/issues/601>.
+ (substitute* "tests/ts/misc/setarch"
+ (("ts_init_subtest.*" all)
+ (string-append
+ all "\n"
+ "ts_skip \"setarch tests are unreliable under QEMU\"")))))
+ (add-before 'check 'disable-lsns-test
+ (lambda _
+ ;; The lsns tests can fail due to ioctl(_, NS_GET_USERNS)
+ ;; returning ENOTTY, indicating this kernel does not
+ ;; support user namespaces. Curiously, this test can fail
+ ;; on i686 even if the same test passes on x86_64 on the
+ ;; same machine. See <https://issues.guix.gnu.org/49933>.
+ (delete-file "tests/ts/lsns/ioctl_ns")))
+ (add-after 'install 'move-static-libraries
+ (lambda _
+ (let ((lib #$output:lib)
+ (static #$output:static))
+
+ ;; Move static libraries to the "static" output.
+ (mkdir-p (string-append static "/lib"))
+ (with-directory-excursion lib
+ (for-each (lambda (file)
+ (rename-file file
+ (string-append static "/"
+ file)))
+ (find-files "lib" "\\.a$"))
+
+ ;; Remove references to the static library from the '.la'
+ ;; files so that Libtool does the right thing when both
+ ;; the shared and static library is available.
+ (substitute* (find-files "lib" "\\.la$")
+ (("old_library=.*") "old_library=''\n"))))))
+ (add-after 'install 'adjust-pkg-config-files
+ (lambda _
+ ;; Drop the unused "prefix=" and "exec_prefix=" variables from
+ ;; the pkg-config files to avoid a cyclic reference on "out".
+ (substitute* (find-files (string-append #$output:lib
+ "/lib/pkgconfig")
+ "\\.pc$")
+ (("^(exec_)?prefix=.*") "")))))))
(inputs
(list file ;for libmagic
ncurses
@@ -1913,21 +1912,6 @@ block devices, UUIDs, TTYs, and many other tools.")
(modify-inputs (package-inputs util-linux)
(prepend eudev)))))
-;; This is mostly equivalent to the upstream release version v2.37.3, except
-;; that the upstream tarball was generated improperly, which breaks the build.
-;; There will not be a v2.37.3-fixed release or anything like that to fix it:
-;; https://github.com/util-linux/util-linux/issues/1577
-(define-public util-linux/fixed
- (hidden-package
- (package
- (inherit util-linux)
- (source (origin
- (inherit (package-source util-linux))
- (patches (append (search-patches "util-linux-CVE-2021-3995.patch"
- "util-linux-CVE-2021-3996.patch")
- (origin-patches (package-source util-linux)))))))))
-
-
(define-public ddate
(package
(name "ddate")
@@ -2008,38 +1992,35 @@ parameters.")
(define-public procps
(package
(name "procps")
- (version "3.3.16")
+ (version "4.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/procps-ng/Production/"
"procps-ng-" version ".tar.xz"))
(sha256
(base32
- "1br0g93ysqhlv13i1k4lfbimsgxnpy5rgs4lxfc9rkzdbpbaqplj"))))
+ "04v5q5cshzyhbwaw4n9l0k8faaz67n11z31vpfaiqynv9rwr4k8g"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build utils)
- (guix build gnu-build-system)
- (srfi srfi-1)
- (srfi srfi-26))
- ,@(if (%current-target-system)
- '(#:configure-flags
- (list
- "ac_cv_func_malloc_0_nonnull=yes"
- "ac_cv_func_realloc_0_nonnull=yes"))
- '())
- #:phases
- (modify-phases %standard-phases
- (add-after
- 'install 'post-install
- ;; Remove commands and man pages redudant with
- ;; Coreutils.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dup (append-map (cut find-files out <>)
- '("^kill" "^uptime"))))
- (for-each delete-file dup)
- #t))))))
+ (list #:modules '((guix build utils)
+ (guix build gnu-build-system)
+ (srfi srfi-1)
+ (srfi srfi-26))
+ #:configure-flags
+ (if (%current-target-system)
+ #~'("ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes")
+ #~'())
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'post-install
+ ;; Remove commands and man pages redudant with
+ ;; Coreutils.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out #$output)
+ (dup (append-map (cut find-files out <>)
+ '("^kill" "^uptime"))))
+ (for-each delete-file dup)))))))
(inputs (list ncurses))
(home-page "https://gitlab.com/procps-ng/procps/")
(synopsis "Utilities that give information about processes")
@@ -2591,16 +2572,14 @@ external rate conversion.")
(define-public iptables
(package
(name "iptables")
- (version "1.8.7")
+ (version "1.8.8")
(source
(origin
(method url-fetch)
(uri (list (string-append "mirror://netfilter.org/iptables/iptables-"
- version ".tar.bz2")
- (string-append "https://www.netfilter.org/projects/iptables/"
- "files/iptables-" version ".tar.bz2")))
+ version ".tar.bz2")))
(sha256
- (base32 "1w6qx3sxzkv80shk21f63rq41c84irpx68k62m2cv629n1mwj2f1"))))
+ (base32 "17w5a4znq8rdj5djcldmy6mbnxq1v88ibssk2mipc1kivj4miivi"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config flex bison))
@@ -2625,6 +2604,8 @@ This package also includes @command{ip6tables}, which is used to configure the
IPv6 packet filter.
Both commands are targeted at system administrators.")
+ (properties
+ '((release-monitoring-url . "https://www.netfilter.org/pub/iptables/")))
(license license:gpl2+)))
(define-public jitterentropy-rngd
@@ -2765,9 +2746,7 @@ that the Ethernet protocol is much simpler than the IP protocol.")
"pkg-config")))
#t))))))
(inputs
- `(("db4" ,bdb)
- ("iptables" ,iptables)
- ("libmnl" ,libmnl)))
+ (list bdb iptables libmnl))
(native-inputs
(list bison flex pkg-config))
;; For tests.
@@ -2868,7 +2847,7 @@ configuration (iptunnel, ipmaddr).")
(define-public libcap
(package
(name "libcap")
- (version "2.62")
+ (version "2.64")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2876,7 +2855,7 @@ configuration (iptunnel, ipmaddr).")
"libcap2/libcap-" version ".tar.xz"))
(sha256
(base32
- "18l3pngsbaahdjzz01rmzrjgcqny4zld685fkq96mq5yr6m5n30r"))))
+ "04qy0z6yhlljb29xxcb2srbdnymcrhsi28wrc705z3861cgmwin8"))))
(build-system gnu-build-system)
(arguments
(list #:phases
@@ -5227,7 +5206,7 @@ Linux Device Mapper multipathing driver:
(define-public libaio
(package
(name "libaio")
- (version "0.3.112")
+ (version "0.3.113")
(source (origin
(method url-fetch)
(uri (list
@@ -5235,37 +5214,16 @@ Linux Device Mapper multipathing driver:
name "-" version ".tar.gz")))
(sha256
(base32
- "14mlqdapjqq1dhpkdgy5z83mvsaz36fcxca7a4z6hinmr7r6415b"))))
+ "02r0g2vfv6kfljplm3ga93w4xw13q2wixbn9hwi7ahqdzp2x2i1c"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
- #~(let ((target #$(%current-target-system)))
- ;; XXX TODO: Replace with simply #$OUTPUT on core-updates.
- (list (string-append "prefix=" #$(if (%current-target-system)
- #~#$output
- #~%output))
- (string-append
- "CC=" (if target
- (string-append (assoc-ref %build-inputs
- "cross-gcc")
- "/bin/" target "-gcc")
- "gcc"))))
+ #~(list (string-append "prefix=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
#:test-target "partcheck" ; need root for a full 'check'
#:phases
#~(modify-phases %standard-phases
- (delete 'configure) ; no configure script
- ;; TODO: Make this phase unconditional on core-updates.
- #$@(if (target-riscv64?)
- '((add-before 'check 'patch-for-riscv-support
- (lambda _
- ;; Taken from the upstream repo:
- ;; https://pagure.io/libaio/c/f322f467c3cd2ac4d8d08a19bd281eabb65433b1?branch=master
- (substitute* "harness/cases/16.t"
- (("(elif defined\\(__aarch64__\\))" all)
- (string-append all " || defined(__riscv)"))
- (("(endif /* __aarch64__)" all)
- (string-append all " || __riscv "))))))
- '()))))
+ (delete 'configure)))) ; no configure script
(home-page "https://pagure.io/libaio")
(synopsis "Linux-native asynchronous I/O access library")
(description
@@ -7229,7 +7187,7 @@ machines (PowerMac G4 is known to work).")
(define-public libmnl
(package
(name "libmnl")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
@@ -7237,7 +7195,7 @@ machines (PowerMac G4 is known to work).")
"libmnl-" version ".tar.bz2"))
(sha256
(base32
- "108zampspaalv44zn0ar9h386dlfixpd149bnxa5hsi8kxlqj7qp"))))
+ "09851ns07399rbz0y8slrlmnw3fn1nakr8d37pxjn5gkks8rnjr7"))))
(build-system gnu-build-system)
(home-page "https://www.netfilter.org/projects/libmnl/")
(synopsis "Netlink utility library")
@@ -7246,6 +7204,8 @@ Netlink developers. There are a lot of common tasks in parsing, validating,
constructing of both the Netlink header and TLVs that are repetitive and easy to
get wrong. This library aims to provide simple helpers that allows you to
re-use code and to avoid re-inventing the wheel.")
+ (properties
+ '((release-monitoring-url . "https://www.netfilter.org/pub/libmnl/")))
(license license:lgpl2.1+)))
(define-public libnftnl
@@ -7276,14 +7236,14 @@ used by nftables.")
;; variant to avoid accidental rebuilds of rust.
(define-public libnftnl/fixed
(package (inherit libnftnl)
- (version "1.2.0")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://netfilter.org/libnftnl/"
"libnftnl-" version ".tar.bz2"))
(sha256
- (base32 "1xblq1cbcxhr6qmjpy98i1qdza148idgz99vbhjc7s4vzvfizc4h"))))
+ (base32 "02kdxp4l1ds5lpkw6rxv6f7icc70am6ik3p9z5l8v48mkm7h1z4y"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))