summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 021e972a89..2bb3900495 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -965,6 +965,18 @@ It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-arm-veyron
(deprecated-package "linux-libre-arm-veyron" linux-libre-arm-generic))
+(define-public linux-libre-arm-generic-5.10
+ (make-linux-libre* linux-libre-5.10-version
+ linux-libre-5.10-source
+ '("armhf-linux")
+ #:defconfig "multi_v7_defconfig"
+ #:extra-version "arm-generic"
+ #:extra-options
+ (append
+ `(;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t))
+ %default-extra-linux-options)))
+
(define-public linux-libre-arm-generic-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source