summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm76
1 files changed, 52 insertions, 24 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 8c850ee850..d3f43a4f60 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 André A. Gomes <andremegafone@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,36 @@
(define-public ecl-1am
(sbcl-package->ecl-package sbcl-1am))
+(define-public sbcl-2am
+ (let ((commit "1d2fd21bbd8f26ec91b962705cab098dd7b5f11c")
+ (revision "0"))
+ (package
+ (name "sbcl-2am")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.common-lisp.net/dkochmanski/2am")
+ (commit commit)))
+ (file-name (git-file-name "cl-2am" version))
+ (sha256
+ (base32 "0zgx4ymyzvfg44z36yr4l87cd9mprajd7sycr2zc67ab6330rynf"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://gitlab.common-lisp.net/dkochmanski/2am")
+ (synopsis "Small testing framework based on 1am")
+ (description
+ "This is a small testing framework for Common Lisp. The entire API
+consists of: @code{test}, @code{is}, @code{signals}, @code{finishes},
+@code{run}, @code{suite} and @code{setf suite}.")
+ (license license:expat))))
+
+(define-public cl-2am
+ (sbcl-package->cl-source-package sbcl-2am))
+
+(define-public ecl-2am
+ (sbcl-package->ecl-package sbcl-2am))
+
(define-public sbcl-check-it
(let ((commit "b79c9103665be3976915b56b570038f03486e62f"))
(package
@@ -542,32 +573,29 @@ testing. It is an extension of the library written by Chris Riesbeck.")
(define-public sbcl-lisp-unit2
;; There is a cyclical dependency between symbol-munger and lisp-unit2.
;; See https://github.com/AccelerationNet/symbol-munger/issues/4
- (let ((commit "fb9721524d1e4e73abb223ee036d74ce14a5505c")
- (revision "1"))
- (package
- (name "sbcl-lisp-unit2")
- (version (git-version "0.2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AccelerationNet/lisp-unit2")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1rsqy8y0jqll6xn9a593848f5wvd5ribv4csry1ly0hmdhfnqzlp"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
- sbcl-symbol-munger))
- (synopsis "Test Framework for Common Lisp")
- (description
- "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
+ (package
+ (name "sbcl-lisp-unit2")
+ (version "0.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AccelerationNet/lisp-unit2")
+ (commit version)))
+ (file-name (git-file-name "cl-lisp-unit2" version))
+ (sha256
+ (base32 "0y7k6fd4mf7ggc8kdrbg8flkj5j7i7ki1350wnj6hqax7cmh4xv5"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
+ sbcl-symbol-munger))
+ (synopsis "Test Framework for Common Lisp")
+ (description
+ "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
style of JUnit for Java. It is a new version of the lisp-unit library written
by Chris Riesbeck.")
- (home-page "https://github.com/AccelerationNet/lisp-unit2")
- (license license:expat))))
+ (home-page "https://github.com/AccelerationNet/lisp-unit2")
+ (license license:expat)))
(define-public cl-lisp-unit2
(sbcl-package->cl-source-package sbcl-lisp-unit2))