summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm84
1 files changed, 83 insertions, 1 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 1cdd7d8300..dd8ef90892 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -5,9 +5,10 @@
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -358,6 +359,44 @@ interactive development model in mind.")
(define-public ecl-fiveam
(sbcl-package->ecl-package sbcl-fiveam))
+(define-public sbcl-hamcrest
+ (let ((commit "a54553e59a70dc5a539b683e79bfcdb0e8bae5c8")
+ (revision "0"))
+ (package
+ (name "sbcl-hamcrest")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/40ants/cl-hamcrest")
+ (commit commit)))
+ (sha256
+ (base32 "181nnb2fjbsdqjqdvwg2x9n1jjalkfzszwdgqcap4py2q63q1kxj"))
+ (file-name (git-file-name "cl-hamcrest" commit))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-iterate
+ sbcl-split-sequence
+ sbcl-cl-ppcre
+ sbcl-alexandria
+ sbcl-rove
+ sbcl-prove))
+ (home-page "https://40ants.com/cl-hamcrest/")
+ (synopsis "Make CL unit tests more readable")
+ (description
+ "@code{cl-hamcrest} is an implementation of the Hamcrest idea in
+Common Lisp. It simplifes unit tests and makes them more readable.
+Hamcrest uses the idea of pattern-matching, to construct matchers from
+different pieces and to apply them to the data.")
+ (license license:bsd-3))))
+
+(define-public cl-hamcrest
+ (sbcl-package->cl-source-package sbcl-hamcrest))
+
+(define-public ecl-cl-hamcrest
+ (sbcl-package->ecl-package sbcl-hamcrest))
+
(define-public sbcl-hu.dwim.stefil
(let ((commit "414902c6f575818c39a8a156b8b61b1adfa73dad"))
(package
@@ -805,6 +844,49 @@ interactive development.")
(define-public ecl-stefil
(sbcl-package->ecl-package sbcl-stefil))
+(define-public sbcl-try
+ (let ((commit "a1fffad2ca328b3855f629b633ab1daaeec929c2")
+ (revision "1"))
+ (package
+ (name "sbcl-try")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/melisgl/try")
+ (commit commit)))
+ (file-name (git-file-name "cl-try" version))
+ (sha256
+ (base32 "03dm2i2y4wiyzz9d25zdxm6gdglnvwali0ylp0rfwpk6wf29sj09"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-cl-ppcre))
+ (inputs
+ (list sbcl-alexandria
+ sbcl-closer-mop
+ sbcl-ieee-floats
+ sbcl-mgl-pax
+ sbcl-trivial-gray-streams))
+ (arguments
+ `(#:asd-files '("try.asdf.asd" "try.asd")
+ ;; FIXME: Get tests to work
+ #:tests? #f))
+ (home-page "https://github.com/melisgl/try")
+ (synopsis "Common Lisp test framework")
+ (description
+ "@code{Try} is a library for unit testing with equal support for
+interactive and non-interactive workflows. Tests are functions, and almost
+everything else is a condition, whose types feature prominently in
+parameterization.")
+ (license license:expat))))
+
+(define-public cl-try
+ (sbcl-package->cl-source-package sbcl-try))
+
+(define-public ecl-try
+ (sbcl-package->ecl-package sbcl-try))
+
(define-public sbcl-unit-test
(let ((commit "266afaf4ac091fe0e8803bac2ae72d238144e735")
(revision "1"))