summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index f0599a95c6..feaa08af38 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -309,15 +309,19 @@ statistical profiler, a code coverage tool, and many other extensions.")
"ftp://ftp.clozure.com/pub/release/1.10/ccl-" version "-"
(match (%current-system)
((or "i686-linux" "x86_64-linux") "linuxx86")
- ("armhf-linux" "linuxarm"))
+ ("armhf-linux" "linuxarm")
+ ;; Prevent errors when querying this package on unsupported
+ ;; platforms, e.g. when running "guix package --search="
+ (_ "UNSUPPORTED"))
".tar.gz"))
(sha256
(base32
(match (%current-system)
((or "i686-linux" "x86_64-linux")
"0mr653q5px05lr11z2mk551m5g47b4wq96vbfibpp0qlc9jp58lc")
- ("armhf"
- "1py02irpmi2qz5rq3h33wfv6impf15z8i2rign6hvhlqn7s99wwh"))))))))
+ ("armhf-linux"
+ "1py02irpmi2qz5rq3h33wfv6impf15z8i2rign6hvhlqn7s99wwh")
+ (_ ""))))))))
(native-inputs
`(("m4" ,m4)
("subversion" ,subversion)))
@@ -339,9 +343,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(chdir (string-append
"lisp-kernel/"
,(match (or (%current-target-system) (%current-system))
- ("i686-linux" "linuxx8632")
+ ("i686-linux" "linuxx8632")
("x86_64-linux" "linuxx8664")
- ("armhf-linux" "linuxarm"))))
+ ("armhf-linux" "linuxarm")
+ ;; Prevent errors when querying this package
+ ;; on unsupported platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED"))))
(substitute* '("Makefile")
(("/bin/rm") "rm"))
(setenv "CC" "gcc")
@@ -362,9 +370,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(bash (assoc-ref inputs "bash"))
(kernel
,(match (or (%current-target-system) (%current-system))
- ("i686-linux" "lx86cl")
+ ("i686-linux" "lx86cl")
("x86_64-linux" "lx86cl64")
- ("armhf-linux" "armcl")))
+ ("armhf-linux" "armcl")
+ ;; Prevent errors when querying this package
+ ;; on unsupported platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED")))
(heap (string-append kernel ".image")))
(mkdir-p libdir)
(mkdir-p bindir)