summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8427a19714..b38efac820 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -262,17 +262,15 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32 "0qjv3z274rbdmb941hy03hl63f4z7bmci234f8dyz4skgfr82d3i"))
- (patches (search-patches "clisp-remove-failing-test.patch"))))
+ (patches (search-patches "clisp-glibc-2.26.patch"
+ "clisp-remove-failing-test.patch"))))
(build-system gnu-build-system)
(inputs `(("libffcall" ,libffcall)
("ncurses" ,ncurses)
("readline" ,readline)
("libsigsegv" ,libsigsegv)))
(arguments
- '(;; XXX The custom configure script does not cope well when passed
- ;; --build=<triplet>.
- #:configure-flags '("CFLAGS=-falign-functions=4"
- "--enable-portability"
+ '(#:configure-flags '("--enable-portability"
"--with-dynamic-ffi"
"--with-dynamic-modules"
"--with-module=bindings/glibc"