summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 2d3ee79339..6e7c5a6e05 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -887,6 +887,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(origin
(method url-fetch)
(uri (llvm-uri "llvm" version))
+ (patches (search-patches "llvm-8-missing-include.patch"))
(sha256
(base32
"0s94lwil98w7zb7cjrbnxli0z7gklb312pkw74xs1d6zk346hgwi"))))))
@@ -936,6 +937,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(origin
(method url-fetch)
(uri (llvm-uri "llvm" version))
+ (patches (search-patches "llvm-8-missing-include.patch"))
(sha256
(base32
"1wydhbp9kyjp5y0rc627imxgkgqiv3dfirbqil9dgpnbaw5y7n65"))))
@@ -996,6 +998,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(base32
"16hwp3qa54c3a3v7h8nlw0fh5criqh0hlr1skybyk0cz70gyx880"))
(patches (search-patches
+ "llvm-8-missing-include.patch"
"llvm-9-fix-bitcast-miscompilation.patch"
"llvm-9-fix-scev-miscompilation.patch"
"llvm-9-fix-lpad-miscompilation.patch"))))
@@ -1055,7 +1058,8 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(sha256
(base32
"1rvm5gqp5v8hfn17kqws3zhk94w4kxndal12bqa0y57p09nply24"))
- (patches (search-patches "llvm-8-fix-build-with-gcc-10.patch"))))
+ (patches (search-patches "llvm-8-fix-build-with-gcc-10.patch"
+ "llvm-8-missing-include.patch"))))
(license license:ncsa)))
(define-public clang-runtime-8