summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 0ecc91294f..7cadba6392 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1124,8 +1124,7 @@ shell command executions.")
"1999bgrh52124a5g4qizav3x257ff2brjr855srpm1jv1nxzbygv"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- ;; Tests are disabled for now due to an issue that affecs guix:
+ `(;; Tests are disabled for now due to an issue that affecs guix:
;; <https://gitlab.com/emilua/emilua/-/issues/22>
#:configure-flags
(list "-Denable_http=true"
@@ -1194,7 +1193,7 @@ enabled.")
(delete 'configure)
(add-before 'build 'patch-lua-calls
(lambda* (#:key inputs #:allow-other-keys)
- (let ((lua (string-append (assoc-ref inputs "lua") "/bin/lua")))
+ (let ((lua (search-input-file inputs "/bin/lua")))
(setenv "LUA" lua)
(substitute* "old/launcher.lua"
(("/usr/bin/env lua") lua))
@@ -1203,7 +1202,7 @@ enabled.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "fennel"
(("/usr/bin/env .*lua")
- (string-append (assoc-ref inputs "lua") "/bin/lua")))
+ (search-input-file inputs "/bin/lua")))
#t))
(delete 'check)
(add-after 'install 'check