summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 4466e5e6d9..36d725a3af 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -963,7 +963,8 @@ mailpack. What can alterMIME do?
w3m
xorg-server-for-tests))
(inputs
- (list boost
+ (list bash-minimal
+ boost
gmime
gobject-introspection ; it is referenced
gtkmm-3
@@ -1174,7 +1175,7 @@ repository and Maildir/IMAP as LOCAL repository.")
#:modules '((guix build gnu-build-system)
(guix build utils)
(guix build emacs-utils))
- #:imported-modules `(,@%gnu-build-system-modules
+ #:imported-modules `(,@%default-gnu-imported-modules
(guix build emacs-utils))
#:tests? #f
#:configure-flags
@@ -1344,7 +1345,7 @@ Notmuch.")
(file-name (string-append name "-" version "-checkout"))))
(build-system python-build-system)
(inputs
- (list python-notmuch python-pygobject gobject-introspection
+ (list bash-minimal python-notmuch python-pygobject gobject-introspection
libnotify gtk+))
(arguments
`(#:phases
@@ -2808,7 +2809,8 @@ DKIM and/or DomainKeys.")
"perl-net-dns"
"perl-timedate"))))))))
(inputs
- (list perl
+ (list bash-minimal
+ perl
perl-crypt-openssl-rsa
perl-cryptx
perl-io-socket-inet6
@@ -3771,7 +3773,11 @@ on the fly. Both programs are written in C and are very fast.")
(base32 "131i2b1yxhnbqkfk4kky40pfanqw2c5lcgbnjhfqp5cvpawpk2ai"))))
(build-system perl-build-system)
(inputs
- (list perl-io-socket-inet6 perl-net-dns perl-net-ssleay perl-socket6)) ; used by perl-io-socket-inet6
+ (list bash-minimal
+ perl-io-socket-inet6
+ perl-net-dns
+ perl-net-ssleay
+ perl-socket6)) ; used by perl-io-socket-inet6
(arguments
`(#:tests? #f ; no tests
#:phases
@@ -3779,8 +3785,7 @@ on the fly. Both programs are written in C and are very fast.")
(add-after 'unpack 'set-build_version
(lambda _
(substitute* "swaks"
- (("\"DEVRELEASE\"") (format #f "\"~a\"" ,version)))
- #true))
+ (("\"DEVRELEASE\"") (format #f "\"~a\"" ,version)))))
(delete 'configure)
(replace 'build
(lambda _
@@ -3789,14 +3794,12 @@ on the fly. Both programs are written in C and are very fast.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(install-file "swaks" (string-append out "/bin"))
- (install-file "swaks.1" (string-append out "/share/man/man1")))
- #t))
+ (install-file "swaks.1" (string-append out "/share/man/man1")))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
"/bin/swaks")
- `("PERL5LIB" ":" = (,(getenv "PERL5LIB"))))
- #t)))))
+ `("PERL5LIB" ":" = (,(getenv "PERL5LIB")))))))))
(home-page "https://jetmore.org/john/code/swaks/")
(synopsis "Featureful SMTP test tool")
(description "Swaks is a flexible, scriptable, transaction-oriented SMTP
@@ -4127,7 +4130,7 @@ It is a replacement for the @command{urlview} program.")
#:select (target-guile-effective-version))
(guix build utils))
#:imported-modules `((guix build guile-build-system)
- ,@%gnu-build-system-modules)
+ ,@%default-gnu-imported-modules)
#:configure-flags '(list "--localstatedir=/var")
@@ -4707,7 +4710,7 @@ ex-like commands on it.")
((guix build emacs-build-system) #:prefix emacs:)
(guix build utils)
(ice-9 string-fun))
- #:imported-modules (,@%gnu-build-system-modules
+ #:imported-modules (,@%default-gnu-imported-modules
(guix build emacs-build-system)
(guix build emacs-utils))
#:make-flags (list (string-append "prefix=" %output)