summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm36
1 files changed, 25 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index eee7d1831f..e1b490e51d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
+;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages dns)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages emacs)
#:use-module (gnu packages enchant)
#:use-module (gnu packages ghostscript)
@@ -319,6 +321,9 @@ and corrections. It is based on a Bayesian filter.")
(base32
"0smxh5ag3cbn92kp49jq950j5m2pivs9kr04prpd1lw62hy7gnhr"))))
(build-system python-build-system)
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("libxslt" ,libxslt))) ; for xsltproc
(inputs `(("python2-pysqlite" ,python2-pysqlite)
("python2-six" ,python2-six)))
(arguments
@@ -328,8 +333,21 @@ and corrections. It is based on a Bayesian filter.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-binary
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-after 'build 'build-documentation
+ (lambda _
+ (substitute* "docs/Makefile"
+ ;; Prevent xmllint and xsltproc from downloading a DTD file.
+ (("a2x -v") "a2x --no-xmllint --xsltproc-opts=--nonet -v"))
+ (zero? (system* "make" "-C" "docs" "man"))))
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man")))
+ (install-file "docs/offlineimap.1" (string-append man "/man1"))
+ (install-file "docs/offlineimapui.7" (string-append man "/man7"))
+ #t)))
+ (add-after 'install-documentation 'wrap-binary
+ (lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/offlineimap")))
(wrap-program bin
@@ -501,18 +519,14 @@ invoking @command{notifymuch} from the post-new hook.")
(define-public notmuch
(package
(name "notmuch")
- (version "0.23")
+ (version "0.23.1")
(source (origin
(method url-fetch)
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
version ".tar.gz"))
(sha256
(base32
- "1f51l34rdhjf8lvafrwybkxdsdwx8k9397m7qxd8rdg2irjmpry5"))
- (patches
- ;; Remove this for the next release. See this thread for context:
- ;; https://notmuchmail.org/pipermail/notmuch/2016/023227.html
- (search-patches "notmuch-emacs-25-compatibility-fix.patch"))))
+ "106ijsnilqf8760z4cq99rqzjsvyaw86d0lgnzz7v95gm4d2l0g8"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "V=1") ; Verbose test output.
@@ -1618,7 +1632,7 @@ some additional standard extensions. It allows ordinary machines to exchange
e-mails with other systems speaking the SMTP protocol.")
(home-page "https://www.opensmtpd.org")
(license (list bsd-2 bsd-3 bsd-4 (non-copyleft "file://COPYING")
- public-domain isc openssl))))
+ public-domain isc license:openssl))))
(define-public opensmtpd-extras
(package
@@ -1681,8 +1695,8 @@ e-mails with other systems speaking the SMTP protocol.")
(assoc-ref %build-inputs "python-2"))
(string-append "--with-lua="
(assoc-ref %build-inputs "lua")))))
- (license (list bsd-2 bsd-3 bsd-4 non-copyleft
- public-domain isc openssl))
+ (license (list bsd-2 bsd-3 bsd-4
+ public-domain isc license:openssl))
(synopsis "Extra tables, filters, and various other addons for OpenSMTPD")
(description
"This package provides extra tables, filters, and various other addons