summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm34
1 files changed, 30 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d1c1c096e5..4944dd7622 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -706,9 +706,9 @@ attachments, create new maildirs, and so on.")
("python2-pygpgme" ,python2-pygpgme)
("python2-notmuch" ,python2-notmuch)))
(home-page "https://github.com/pazz/alot")
- (synopsis "Commandline MUA using notmuch")
+ (synopsis "Command-line MUA using @code{notmuch}")
(description
- "Alot is an experimental terminal mail user agent (MUA) based on
+ "Alot is an experimental terminal mail user agent (@dfn{MUA}) based on
@code{notmuch} mail. It is written in Python using the @code{urwid} toolkit.")
(license gpl3+)))
@@ -1011,7 +1011,7 @@ compresses it.")
(define-public claws-mail
(package
(name "claws-mail")
- (version "3.17.0")
+ (version "3.17.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1019,7 +1019,7 @@ compresses it.")
".tar.xz"))
(sha256
(base32
- "119y6q9p8zwm2xqlbkgqd119a529kjqlyldmb4h940z6c2qyjhqm"))))
+ "1wknxbwyzm5xjh3cqmddcxmvp1rkp301qga5n5rgfi7vcd0myyvm"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("bogofilter" ,bogofilter)
@@ -2596,3 +2596,29 @@ processes mailboxes based on the results. It can be used to delete, copy,
move, flag, etc. messages residing in mailboxes at the same or different mail
servers. The 4rev1 and 4 versions of IMAP are supported.")
(license license:expat)))
+
+(define-public urlscan
+ (package
+ (name "urlscan")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urlscan" version))
+ (sha256
+ (base32
+ "133f28bisr4xj0nihpwpil8dyadss62mp8qgqdyzd676hg9xjfyc"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-urwid" ,python-urwid)))
+ (home-page "https://github.com/firecat53/urlscan")
+ (synopsis "View/select the URLs in an email message or file")
+ (description
+ "Urlscan is a small program that is designed to integrate with the
+@code{mutt} mailreader to allow you to easily launch a Web browser for URLs
+contained in email messages. It parses an email message or file and scans it
+for URLs and email addresses. It then displays the URLs and their context
+within the message, and allows you to choose one or more URLs to send to your
+Web browser. Alternatively, it send a list of all URLs to stdout. It is a
+replacement for the @code{urlview} program.")
+ (license gpl2)))