summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index f640c8bb12..33fa2ea279 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -73,7 +73,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inherit base)
(source (origin (inherit (package-source base))
(patches (append (search-patches
- "glibc-bootstrap-system.patch")
+ (match (package-version base)
+ ("2.39" "glibc-2.39-bootstrap-system.patch")
+ (_ "glibc-bootstrap-system.patch")))
(origin-patches (package-source base))))))
(arguments
(substitute-keyword-arguments (package-arguments base)