summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cbb1112d9f..003e8c0286 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -29,7 +29,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2018 Amin Bandali <mab@gnu.org>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 Robert Smith <robertsmith@posteo.net>
@@ -907,12 +907,12 @@ incompatible with HDF5.")
(find-files ex ".*"))
(delete-file-recursively ex))
#t)))))
- (home-page "http://www.hdfgroup.org")
+ (home-page "https://www.hdfgroup.org")
(synopsis "Management suite for extremely large and complex data")
(description "HDF5 is a suite that makes possible the management of
extremely large and complex data collections.")
(license (license:x11-style
- "http://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
+ "https://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
(define-public hdf5-1.10
(package (inherit hdf5)
@@ -941,7 +941,7 @@ extremely large and complex data collections.")
(origin
(method url-fetch)
(uri (string-append
- "http://www.hdfgroup.org/ftp/HDF5/releases/HDF-JAVA/hdfjni-"
+ "https://www.hdfgroup.org/ftp/HDF5/releases/HDF-JAVA/hdfjni-"
version "/src/CMake-hdfjava-" version ".tar.gz"))
(sha256
(base32 "0m1gp2aspcblqzmpqbdpfp6giskws85ds6p5gz8sx7asyp7wznpr"))
@@ -1174,7 +1174,7 @@ Swath).")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.hdfgroup.org/ftp/HDF5/tools/"
+ (uri (string-append "https://www.hdfgroup.org/ftp/HDF5/tools/"
"h5check/src/h5check-" version ".tar.gz"))
(sha256
(base32
@@ -1269,7 +1269,7 @@ similar to MATLAB, GNU Octave or SciPy.")
#t)))
#:parallel-tests? #f)) ;various race conditions
- (home-page "http://www.unidata.ucar.edu/software/netcdf/")
+ (home-page "https://www.unidata.ucar.edu/software/netcdf/")
(synopsis "Library for scientific data")
(description "NetCDF is an interface for scientific data access and a
software library that provides an implementation of the interface. The netCDF
@@ -1920,13 +1920,13 @@ September 2004}")
(copy-recursively exdir exdir')
(delete-file-recursively exdir)
#t))))))
- (home-page "http://www.mcs.anl.gov/petsc")
+ (home-page "https://www.mcs.anl.gov/petsc")
(synopsis "Library to solve PDEs")
(description "PETSc, pronounced PET-see (the S is silent), is a suite of
data structures and routines for the scalable (parallel) solution of
scientific applications modeled by partial differential equations.")
(license (license:non-copyleft
- "http://www.mcs.anl.gov/petsc/documentation/copyright.html"))))
+ "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))))
(define-public petsc-complex
(package (inherit petsc)
@@ -2643,7 +2643,7 @@ YACC = bison -pscotchyy -y -b y
(install-file f (string-append out "/lib")))
(find-files "../lib/" ".*metis\\..*"))
#t))))))
- (home-page "http://www.labri.fr/perso/pelegrin/scotch/")
+ (home-page "https://www.labri.fr/perso/pelegrin/scotch/")
(synopsis "Programs and libraries for graph algorithms")
(description "SCOTCH is a set of programs and libraries which implement
the static mapping and sparse matrix reordering algorithms developed within
@@ -4277,7 +4277,7 @@ symmetric matrices.")
(base32
"1687xpjjzig27y2pnqv7hv09smpijyfdpz7qjgmcxf4shfajlfkc"))))
(build-system cmake-build-system)
- (home-page "http://libelemental.org")
+ (home-page "https://github.com/elemental/Elemental")
(native-inputs
`(("gfortran" ,gfortran)))
(inputs