summaryrefslogtreecommitdiff
path: root/gnu/packages/mercury.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mercury.scm')
-rw-r--r--gnu/packages/mercury.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/mercury.scm b/gnu/packages/mercury.scm
index fe02b34a97..1c7f5c5f55 100644
--- a/gnu/packages/mercury.scm
+++ b/gnu/packages/mercury.scm
@@ -31,7 +31,7 @@
#:use-module (gnu packages shells)
#:use-module (gnu packages bison)
#:use-module (gnu packages pkg-config)
- #:use-module (ice-9 match)) ; match-lambda
+ #:use-module ((ice-9 match) #:select (match-lambda)))
;; NOTE: Mercury uses a tightly coupled fork of BDWGC and
;; libatomic-ops. When updating the package, please check the GitHub
@@ -100,8 +100,7 @@
(invoke "mv" orig-name new-name)
(with-directory-excursion new-name
(apply patch-source-shebangs (list #:source src)))))
- `((,libatomic-ops "source" "boehm_gc/libatomic_ops")))
- #t)))
+ `((,libatomic-ops "source" "boehm_gc/libatomic_ops"))))))
(add-after 'replace-boehm-gc 'patch-paths
(lambda _
(substitute*
@@ -133,8 +132,7 @@
"boehm_gc/Makefile.direct")
(("/bin/sh") (which "sh"))
(("/bin/pwd") (which "pwd"))
- (("/bin/rm") (which "rm")))
- #t)))))
+ (("/bin/rm") (which "rm"))))))))
(native-inputs
`(("texinfo" ,texinfo)
("flex" ,flex)
@@ -227,12 +225,10 @@ separate compilation, and numerous optimization/time trade-offs.")
(("/bin/sh") (which "sh"))
(("/bin/pwd") (which "pwd"))
(("/bin/rm") (which "rm"))
- (("boehm_gc/.git") "boehm_gc"))
- #t))
+ (("boehm_gc/.git") "boehm_gc"))))
(replace 'bootstrap
(lambda _
- (invoke "./prepare.sh")
- #t))))))
+ (invoke "./prepare.sh")))))))
;; TODO: Uncomment phase when tests are enabled.
;; (replace 'check
;; (lambda _