summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index ae887fa24d..49224a7ba5 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017,2018 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017, 2018, 2019 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -63,14 +63,14 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(define-public nyacc
(package
(inherit nyacc-0.86)
- (version "0.94.0")
+ (version "0.99.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/nyacc/nyacc-"
version ".tar.gz"))
(sha256
(base32
- "12qnzwm1n3j8z7hbr9hy2wka9a1aasm2rvnpnvdxkjcsbdzj8fn4"))
+ "0hl5qxx19i4x1r0839sxm19ziqq65g4hy97yik81cc2yb9yvgyv3"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -94,22 +94,19 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(define-public mes
(package
(name "mes")
- (version "0.19")
+ (version "0.20")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mes/"
"mes-" version ".tar.gz"))
(sha256
(base32
- "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
+ "04pajp8v31na34ls4730ig5f6miiplhdvkmsb9ls1b8bbmw2vb4n"))))
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"))
(propagated-inputs
`(("mescc-tools" ,mescc-tools)
-
- ;; XXX: MesCC appears to enter an infinite loop (?) while building
- ;; crt1.o when we switch to nyacc 0.94.
- ("nyacc" ,nyacc-0.86)))
+ ("nyacc" ,nyacc)))
(native-inputs
`(("guile" ,guile-2.2)
,@(let ((target-system (or (%current-target-system)
@@ -141,7 +138,7 @@ Guile.")
(define-public mescc-tools
(package
(name "mescc-tools")
- (version "0.5.2")
+ (version "0.6.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -151,11 +148,12 @@ Guile.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "01x7bhmgwyf6mc2g1hcvibhps98nllacqm4f0j5l51b1mbi18pc2"))))
+ "06jpvq6xfjzn2al6b4rdwd3zv3h4cvilc4n9gqcnjr9cr6wjpw2n"))))
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"))
(arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
#:test-target "test"
#:phases (modify-phases %standard-phases
(delete 'configure))))