summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm23
1 files changed, 7 insertions, 16 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 45020f31b0..eb1ab34aff 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -217,7 +217,8 @@ identi.ca and status.net).")
'("intltool.m4" "libtool.m4" "lt~obsolete.m4"
"ltoptions.m4" "ltsugar.m4" "ltversion.m4")))
(delete-file-recursively "build-aux")
- (delete-file "po/Makefile.in.in")))))
+ (delete-file "po/Makefile.in.in")
+ #t))))
(build-system gnu-build-system)
(native-inputs `(("autoconf" ,autoconf)
("autoconf-archive" ,autoconf-archive)
@@ -243,13 +244,13 @@ identi.ca and status.net).")
#:phases
(modify-phases %standard-phases
;; Release 2.12.4 wasn't properly bootstrapped. Later ones might be!
- (add-after 'unpack 'bootstrap
+ (add-before 'boostrap 'copy-intltool-makefile
(lambda* (#:key inputs #:allow-other-keys)
;; This file is still required for autoreconf.
(copy-file (string-append (assoc-ref inputs "intltool")
"/share/intltool/Makefile.in.in")
"po/Makefile.in.in")
- (zero? (system* "autoreconf" "-fiv")))))))
+ #t)))))
(synopsis "Graphical IRC Client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main
@@ -1068,7 +1069,9 @@ into existing applications.")
"1lw6807qrbmvzbrjn1rna1dhir2k70xpcjvyjn45y35hav333a42"))
;; psycmp3 currently depends on MP3::List and rxaudio (shareware),
;; we can add it back when this is no longer the case.
- (snippet '(delete-file "contrib/psycmp3"))))
+ (snippet '(begin
+ (delete-file "contrib/psycmp3")
+ #t))))
(build-system perl-build-system)
(inputs
`(("perl-curses" ,perl-curses)
@@ -1373,12 +1376,6 @@ is also scriptable and extensible via Guile.")
(base32
"0iaj56fkd5bjvqpvq3324ni895rmbj1akbfqipjydnghfwaym4z6"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
- (lambda _
- (zero? (system* "./bootstrap.sh")))))))
(inputs
`(("expat" ,expat)
("openssl" ,openssl)))
@@ -1408,12 +1405,6 @@ manual SSL certificate verification.")
(base32
"1hzwdax4nsz0fncf5bjfza0cn0lc6xsf38y569ql1gg5hvwr6169"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
- (lambda _
- (zero? (system* "./bootstrap.sh")))))))
(inputs
`(("expat" ,expat)
("openssl" ,openssl)))