summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2e3afb510e..4856df732e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,6 +60,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
@@ -3189,6 +3191,37 @@ API. Mattermost is not required.")
(home-page "https://github.com/42wim/matterbridge")
(license license:asl2.0)))
+(define-public pounce
+ (package
+ (name "pounce")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.causal.agency/pounce/snapshot/pounce-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1w4x34bspkqvk9p7bfj0zmvmbzvxb7lxrrr3g6lrfdj9f3qzfxpp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;there are no tests
+ #:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("universal-ctags" ,universal-ctags)))
+ (inputs
+ `(("libressl" ,libressl)))
+ (home-page "https://code.causal.agency/june/pounce")
+ (synopsis "Simple multi-client TLS-only IRC bouncer")
+ (description
+ "@command{pounce} is a multi-client, TLS-only IRC bouncer. It maintains
+a persistent connection to an IRC server, acting as a proxy and buffer for
+a number of clients.")
+ (license license:gpl3+)))
+
(define-public weechat-matrix
(package
(name "weechat-matrix")