summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 772fe411ef..a920da76fb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -827,17 +827,15 @@ It is a fork of Clementine aimed at music collectors and audiophiles.")
"1k50z99v2yqshycx6mbk4g5bsaalg5dgzjv3xvwq14abwkw44hli"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; cmus does not include tests
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; It's an idiosyncratic configure script that doesn't
- ;; understand --prefix=..; it wants prefix=.. instead.
- (invoke "./configure"
- (string-append "prefix=" out))
- #t))))))
+ (list
+ #:tests? #f ; cmus does not include tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ ;; It's an idiosyncratic configure script that doesn't
+ ;; understand --prefix=..; it wants prefix=.. instead.
+ (invoke "./configure" (string-append "prefix=" #$output)))))))
;; TODO: cmus optionally supports the following formats, which haven't yet
;; been added to Guix:
;;