summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7eb2896963..0899999576 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -401,7 +401,7 @@ many input formats and provides a customisable Vi-style user interface.")
"Clarinet in Bb.denemo"))
#t)))))
(native-inputs
- `(("glib:bin", glib "bin") ; for gtester
+ `(("glib:bin" ,glib "bin") ; for gtester
("pkg-config" ,pkg-config)))
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -419,7 +419,7 @@ many input formats and provides a customisable Vi-style user interface.")
("libsndfile" ,libsndfile)
("libtool" ,libtool)
("libxml2" ,libxml2)
- ("lilypond", lilypond)
+ ("lilypond" ,lilypond)
("portaudio" ,portaudio)
("portmidi" ,portmidi)
("rubberband" ,rubberband)))
@@ -1756,10 +1756,10 @@ projects.")
(patches (list (search-patch "portmidi-modular-build.patch")))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; tests cannot be linked
+ `(#:tests? #f ; tests cannot be linked
+ #:build-type "Release" ; needed to have PMALSA set
#:configure-flags
(list "-DPORTMIDI_ENABLE_JAVA=Off"
- "-DCMAKE_BUILD_TYPE=Release" ; needed to have PMALSA set
"-DPORTMIDI_ENABLE_TEST=Off"))) ; tests fail linking
(inputs
`(("alsa-lib" ,alsa-lib)))
@@ -2520,7 +2520,7 @@ websites such as Libre.fm.")
(build-system python-build-system)
(propagated-inputs
`(("python-requests" ,python-requests)
- ("eyed3", eyed3)
+ ("eyed3" ,eyed3)
("python-beautifulsoup4" ,python-beautifulsoup4)
("youtube-dl" ,youtube-dl)))
(arguments