summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3ac5be5c8c..2850d309ca 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -906,6 +906,7 @@ add_library( rapidjson INTERFACE IMPORTED )"))
(lambda* (#:key inputs #:allow-other-keys)
;; Link with required static libraries, because we're not
;; using the bundled version of withershins.
+ ;; Also add pthread for fixing a linker error.
(substitute* "source/build/CMakeLists.txt"
(("withershins" line)
(string-append line "\n"
@@ -914,6 +915,7 @@ add_library( rapidjson INTERFACE IMPORTED )"))
(assoc-ref inputs "libiberty")
"/lib/libiberty.a\n"
"dl\n"
+ "pthread\n"
"z\n")))
#t)))))
(inputs
@@ -1237,6 +1239,13 @@ mixing, FFT scopes, MIDI automation and full scriptability in Scheme.")
(substitute* "bristol/Makefile.in"
(("-msse -mfpmath=sse") "")))
#t))
+ ;; alsa-lib 1.1.x no longer provides iatomic.h. That's okay because
+ ;; bristol actually doesn't use it.
+ (add-after 'unpack 'do-not-use-alsa-iatomic
+ (lambda _
+ (substitute* "libbristolaudio/audioEngineJack.c"
+ (("#include <alsa/iatomic.h>") ""))
+ #t))
;; We know that Bristol has been linked with JACK and we don't have
;; ldd, so we can just skip this check.
(add-after 'unpack 'do-not-grep-for-jack