summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3163e6a8f6..13a6ecc36f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1777,6 +1777,42 @@ programming methods as well as for realizing complex systems for large-scale
projects.")
(license license:bsd-3)))
+(define-public libpd
+ (package
+ (name "libpd")
+ (version "0.11.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libpd/libpd.git")
+ (commit version)
+ (recursive? #t))) ; for the 'pure-data' submodule
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1bcg1d9iyf9n37hwwphmih0c8rd1xcqykil5z1cax6xfs76552nk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make" "install"
+ (string-append "prefix=" out)
+ ;; XXX: Fix the last 2 lines of 'install' target.
+ "LIBPD_IMPLIB=NO"
+ "LIBPD_DEF=NO")))))))
+ (home-page "http://libpd.cc/")
+ (synopsis "Pure Data as an embeddable audio synthesis library")
+ (description
+ "Libpd provides Pure Data as an embeddable audio synthesis library. Its
+main purpose is to liberate raw audio rendering from audio and MIDI drivers.")
+ (license license:bsd-3)))
+
(define-public portmidi
(package
(name "portmidi")
@@ -2429,6 +2465,47 @@ and managing stations, can be controlled remotely via fifo, and can run
event-based scripts for scrobbling, notifications, etc.")
(license license:expat)))
+(define-public picard
+ (package
+ (name "picard")
+ (version "2.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://musicbrainz.osuosl.org/pub/musicbrainz/"
+ "picard/picard-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ds3ylpqn717fnzcjrfn05v5xram01bj6n3hwn9igmkd1jgf8vhc"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "picard/const/__init__.py"
+ (("pyfpcalc")
+ (string-append
+ "pyfpcalc', '"
+ (assoc-ref inputs "chromaprint") "/bin/fpcalc")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/"))))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("chromaprint" ,chromaprint)
+ ("python-pyqt" ,python-pyqt)
+ ("python-mutagen" ,python-mutagen)))
+ (home-page "https://picard.musicbrainz.org/")
+ (synopsis "Graphical music tagging application")
+ (description
+ "MusicBrainz Picard is a music tagging application, supporting multiple
+formats, looking up tracks through metadata and audio fingerprints.")
+ (license license:gpl2+)))
+
(define-public python-mutagen
(package
(name "python-mutagen")