summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm32
1 files changed, 9 insertions, 23 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cd06aeddda..6b218376b7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -52,7 +52,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2023 Antero Mejr <antero@mailbox.org>
-;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;;
;;; This file is part of GNU Guix.
@@ -1673,15 +1673,7 @@ typographic detail of symbols on the page.")
(sha256
(base32
"0wma9vzn42h1rhbzh2dwjsrzjhsi1yqdgn6wx1dfk78vaki6prd8"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" ".")
- #t))))))
+ (build-system pyproject-build-system)
(native-inputs
(list lilypond
python-black
@@ -1691,7 +1683,8 @@ typographic detail of symbols on the page.")
python-mypy
python-pytest
python-pytest-cov
- python-pytest-helpers-namespace))
+ python-pytest-helpers-namespace
+ python-sphinx-autodoc-typehints))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -1715,15 +1708,7 @@ and manipulating rhythms such as accelerandi, taleas, and more.")
(sha256
(base32
"05hr2lr6myzi493k8vc19cqzraxxnbdwlckwbnras19l5g5ns38x"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "tests")
- #t))))))
+ (build-system pyproject-build-system)
(native-inputs
(list lilypond
python-black
@@ -1733,7 +1718,8 @@ and manipulating rhythms such as accelerandi, taleas, and more.")
python-mypy
python-pytest
python-pytest-cov
- python-pytest-helpers-namespace))
+ python-pytest-helpers-namespace
+ python-sphinx-autodoc-typehints))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -3821,7 +3807,7 @@ event-based scripts for scrobbling, notifications, etc.")
(define-public picard
(package
(name "picard")
- (version "2.10")
+ (version "2.11")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3829,7 +3815,7 @@ event-based scripts for scrobbling, notifications, etc.")
"picard/picard-" version ".tar.gz"))
(sha256
(base32
- "0f9rvif9m83jhal9n9x8kks17c0cgcipi1hjqmki7a296lz175ss"))))
+ "0ppq2n9jf8c8r8p9dkpcyipd2psr9hg0zbd5hcdsicili25336j4"))))
(build-system python-build-system)
(arguments
(list