summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d7e78cb630..c962a8d821 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -87,17 +87,22 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+;; The gnu.org ‘home’ for this GNU project is a directory listing with 1.6.0 as
+;; the latest version. The author's git repository, mentioned in the 1.6.0
+;; README and otherwise legit-looking, contains a proper 1.7.0 release tarball
+;; with many OUI updates. Use it, even though it's also several years old now.
(define-public macchanger
(package
(name "macchanger")
- (version "1.6.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/"
- name "/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "1xsiivjjyhqcs6dyjcshrnxlgypvyfzacjz7gcjgl88xiw9lylri"))))
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alobbs/macchanger/"
+ "releases/download/" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1gs5m0jxyprdp00w2qkbnaqm3ilkjz0q1gqdg4nzdm8g4xy73qns"))))
(build-system gnu-build-system)
(home-page "https://www.gnu.org/software/macchanger/")
(synopsis "Viewing and manipulating MAC addresses of network interfaces")