summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c7c473a4cc..b3fee16627 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -59,7 +59,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix svn-download)
- #:use-module (guix utils))
+ #:use-module (guix utils)
+ #:use-module (srfi srfi-1))
;; A shortcut for files from ocaml forge. Downloaded files are computed from
;; their number, not their name.
@@ -1126,8 +1127,22 @@ a camlp4-based tool that allows to instrument your application before running
tests. After application execution, it is possible to generate a report in HTML
format that is the replica of the application source code annotated with code
coverage information.")
+ (properties `((ocaml4.01-variant . ,(delay ocaml4.01-bisect))))
(license license:gpl3+)))
+(define-public ocaml4.01-bisect
+ (let ((base (package-with-ocaml4.01 (strip-ocaml4.01-variant ocaml-bisect))))
+ (package
+ (inherit base)
+ (arguments
+ `(#:ocaml ,ocaml-4.01
+ ;; Camlp4 is included with OCaml 4.01, so do not include it as a
+ ;; separate input.
+ ,@(strip-keyword-arguments '(#:make-flags) (package-arguments base))))
+ (native-inputs `(,@(alist-delete "camlp4" (package-native-inputs base))))
+ (propagated-inputs
+ `(,@(alist-delete "camlp4" (package-propagated-inputs base)))))))
+
(define-public ocaml-bitstring
(package
(name "ocaml-bitstring")