summaryrefslogtreecommitdiff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm50
1 files changed, 40 insertions, 10 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index d9b2f9dda0..549b82307b 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +21,8 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (gnu packages mit-krb5)
+ #:use-module (gnu packages pkg-config)
#:use-module (guix build-system gnu))
(define-public libtirpc
@@ -36,16 +39,14 @@
"18a337wa4amf0k21wnimp3yzs5l3cxqndz4x3x8bm993zhfy5hs5"))))
(build-system gnu-build-system)
(arguments
- '(;; Doesn't work with GNU GSS.
- #:configure-flags '("--disable-gssapi")
-
- #:phases (alist-cons-after
- 'unpack 'remote-dangling-symlink
- (lambda _
- ;; Remote the dangling symlinks since it breaks the
- ;; 'patch-source-shebangs' file tree traversal.
- (delete-file "INSTALL"))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remote-dangling-symlink
+ (lambda _
+ ;; Remove the dangling symlinks since it breaks the
+ ;; 'patch-source-shebangs' file tree traversal.
+ (delete-file "INSTALL"))))))
+ (inputs `(("mit-krb5" ,mit-krb5)))
(home-page "http://sourceforge.net/projects/libtirpc/")
(synopsis "Transport-independent Sun/ONC RPC implementation")
(description
@@ -53,3 +54,32 @@
procedure calls) protocol in a transport-independent manner. It supports both
IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
(license bsd-3)))
+
+(define-public rpcbind
+ (package
+ (name "rpcbind")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ version "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0yyjzv4161rqxrgjcijkrawnk55rb96ha0pav48s03l2klx855wq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ `("--with-systemdsystemunitdir=no")))
+ (inputs
+ `(("libtirpc" ,libtirpc)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://rpcbind.sourceforge.net/")
+ (synopsis "Server to convert RPC program numbers into universal addresses")
+ (description
+ "@command{Rpcbind} is a server that converts RPC program numbers into
+universal addresses.")
+ (license bsd-3)))
+