summaryrefslogtreecommitdiff
path: root/gnu/packages/opencl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/opencl.scm')
-rw-r--r--gnu/packages/opencl.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 940f52587e..c2715b498b 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -139,7 +139,9 @@
(native-search-paths
(list (search-path-specification
(variable "OCL_ICD_VENDORS")
- (files '("etc/OpenCL/vendors")))))
+ (files '("etc/OpenCL/vendors"))
+ ;; Only supports a single directory.
+ (separator #f))))
(home-page "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
(inputs (list opencl-headers))
(synopsis "OpenCL Installable Client Driver")
@@ -290,8 +292,7 @@ back-end for the LLVM compiler framework.")
(native-inputs
(list libltdl pkg-config))
(inputs
- (list clang
- `(,hwloc-2 "lib") llvm opencl-icd-loader))
+ (list clang-9 llvm-9 `(,hwloc-2 "lib") opencl-icd-loader))
(arguments
`(#:configure-flags
(list "-DENABLE_ICD=ON"