summaryrefslogtreecommitdiff
path: root/gnu/packages/openpgp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openpgp.scm')
-rw-r--r--gnu/packages/openpgp.scm39
1 files changed, 10 insertions, 29 deletions
diff --git a/gnu/packages/openpgp.scm b/gnu/packages/openpgp.scm
index 40df62a6d7..422e9bdcd6 100644
--- a/gnu/packages/openpgp.scm
+++ b/gnu/packages/openpgp.scm
@@ -97,49 +97,31 @@ environments.")
(license license:gpl2+)))
(define-public rnp
- ;; Packaging the currently released version requires a large number of
- ;; patches. For now, we package a snapshot instead.
- (let ((commit "203224f0b1505dba17837c03da603e5b98ab125a")
- (revision "0")
- (last-version "0.13.1")
- (day-of-release "2020-07-21"))
+ (let ((day-of-release "2022-09-22"))
(package
(name "rnp")
- (version (git-version last-version revision commit))
+ (version "0.16.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rnpgp/rnp")
- (commit commit)))
- (file-name
- (string-append name "-" (string-take commit 7) "-checkout"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1rnwhc9ys4v4mv584hmmrl0ycnqmsaigpffzm31qq337hz24zqya"))
- (patches
- (search-patches "rnp-unbundle-googletest.patch"
- "rnp-disable-ruby-rnp-tests.patch"
- "rnp-add-version.cmake.patch"))))
+ "13z5kxm48a72w4m2crwgdjdng4a4pwxsd72r2z3a4pcakfp2swi8"))))
(build-system cmake-build-system)
(arguments `(#:configure-flags
'("-DBUILD_SHARED_LIBS=on"
- "-DBUILD_TESTING=on")
+ "-DBUILD_TESTING=on"
+ "-DDOWNLOAD_GTEST=off"
+ "-DDOWNLOAD_RUBYRNP=off")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fixes
(lambda* (#:key inputs #:allow-other-keys)
- (copy-recursively (assoc-ref inputs "googletest-source")
- "src/tests/googletest-src")
(substitute* "src/tests/support.cpp"
(("\"cp\"") (string-append "\"" (which "cp") "\"")))
- ;; Produce a version stamp in the format the upstream
- ;; project uses for unreleased revisions.
- (with-output-to-file "version.txt"
- (lambda _
- (display
- (string-append ,last-version
- "-" ,revision
- "-g" ,(string-take commit 7)))))
#t))
(replace 'check
(lambda _
@@ -149,11 +131,10 @@ environments.")
(invoke "faketime" ,day-of-release "make" "test"))))))
(native-inputs
`(("gnupg" ,gnupg) ; for tests
- ("googletest-source" ,(package-source googletest)) ; for tests
+ ("googletest" ,googletest)
("libfaketime" ,libfaketime) ; for tests
("pkg-config" ,pkg-config)
- ("python" ,python)
- ("python2" ,python-2.7)))
+ ("python" ,python)))
(inputs (list botan bzip2 json-c zlib))
(synopsis
"RFC4880-compliant OpenPGP library written in C++")