summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm60
1 files changed, 37 insertions, 23 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 37ff78d93a..dd3e107636 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -99,6 +99,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -176,8 +177,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "1.4.0")
- (commit "4c94b9e983bc51d9504655f1e7727c4f6d14b6b7")
- (revision 18))
+ (commit "37719d3ec8db7f2380903c2ac6e4efb2e4639cc7")
+ (revision 20))
(package
(name "guix")
@@ -193,7 +194,7 @@
(commit commit)))
(sha256
(base32
- "19lqlfafs5mrnciw4jz4iccx5zzhj4pyb20bz6cdqcqbf9nmkfp1"))
+ "05x0bqxzxz2d1l9cwax6cchfikvf46sv3b0fkwb8a2bk42v8bgyz"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -494,7 +495,7 @@ $(prefix)/etc/openrc\n")))
("graphviz" ,graphviz-minimal)
("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
("help2man" ,help2man)
- ("po4a" ,po4a)))
+ ("po4a" ,po4a-minimal)))
(inputs
`(("bash-minimal", bash-minimal)
("bzip2" ,bzip2)
@@ -1006,8 +1007,8 @@ transactions from C or Python.")
(license license:gpl2+)))
(define-public bffe
- (let ((commit "bdfaab91e82d7d43c35405da3b18c46cde8096de")
- (revision "5"))
+ (let ((commit "7df2aa647d11342e3a446f44ef7626e58a1d5902")
+ (revision "6"))
(package
(name "bffe")
(version (git-version "0" revision commit))
@@ -1018,7 +1019,7 @@ transactions from C or Python.")
(commit commit)))
(sha256
(base32
- "0qwnd49apwdx8wrfms2spii1kdg5ashf4591kyfyr89070jjmpa7"))
+ "04gg21rjl3c1l8i2wnq8w1w6zfh2qmp9ay839ll90c1jf9bc3sn4"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(native-inputs
@@ -1547,8 +1548,8 @@ environments.")
"0k9zkdyyzir3fvlbcfcqy17k28b51i20rpbjwlx2i1mwd2pw9cxc")))))))
(define-public guix-build-coordinator
- (let ((commit "14e18eed98d1836662d8787d08f7a37cf8c2f69d")
- (revision "100"))
+ (let ((commit "1ecad692a75402872b7b366859f364a421727925")
+ (revision "105"))
(package
(name "guix-build-coordinator")
(version (git-version "0" revision commit))
@@ -1559,7 +1560,7 @@ environments.")
(commit commit)))
(sha256
(base32
- "1vv1l6y80ymqi7qz70bfq4is4y1xh21jm4d4gapn63931ac4fiij"))
+ "061dxiiqlgzz28ckwj7nl4kjkj110gw7n1d9hwaz4cmv9hkhn7by"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -1673,6 +1674,16 @@ outputs of those builds.")
(package
(inherit guix-build-coordinator)
(name "guix-build-coordinator-agent-only")
+ (arguments
+ (substitute-keyword-arguments (package-arguments guix-build-coordinator)
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'install 'strip-non-agent-files
+ (lambda _
+ (delete-file-recursively
+ (string-append #$output "/share/guix-build-coordinator"))
+ (delete-file
+ (string-append #$output "/bin/guix-build-coordinator"))))))))
(native-inputs
(list pkg-config
autoconf
@@ -1688,17 +1699,16 @@ outputs of those builds.")
guile-next))
(inputs
(list guile-next
- bash-minimal
- (libc-utf8-locales-for-target)))
- (propagated-inputs
- (list guile-prometheus
+ guix
+ guile-prometheus
guile-gcrypt
guile-json-4
guile-lib
guile-lzlib
guile-zlib
- guix
- guile-gnutls))
+ guile-gnutls
+ bash-minimal
+ (libc-utf8-locales-for-target)))
(description
"The Guix Build Coordinator helps with performing lots of builds across
potentially many machines, and with doing something with the results and
@@ -1796,8 +1806,8 @@ in an isolated environment, in separate namespaces.")
(license license:gpl3+)))
(define-public nar-herder
- (let ((commit "ffda727a3b6bd45851662159709a1927a1ee0c1d")
- (revision "27"))
+ (let ((commit "bbf5119200b844fdb59b54d87fa01cc6abee46c2")
+ (revision "33"))
(package
(name "nar-herder")
(version (git-version "0" revision commit))
@@ -1808,7 +1818,7 @@ in an isolated environment, in separate namespaces.")
(commit commit)))
(sha256
(base32
- "1qg8s68prdv3qgwx63k4zfvsida64jq6fcl06zffbkbl672rnrzl"))
+ "12ddwy65px2mryv9x5h1yvm8wn5h6fscp4zamynaqyajnlszj68r"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -2025,14 +2035,14 @@ the boot loader configuration.")
(define-public flatpak
(package
(name "flatpak")
- (version "1.14.4")
+ (version "1.14.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
version "/flatpak-" version ".tar.xz"))
(sha256
- (base32 "16b7f7n2mms6zgm0lj3fn86ny11xjn8cd3mrk1slwhvwnv8dnd4a"))
+ (base32 "0ij93vl9skcfdfgkmgd80q0q4c6q39dss4rds7phxizqqsr3d3sk"))
(patches
(search-patches "flatpak-fix-path.patch"
"flatpak-unset-gdk-pixbuf-for-sandbox.patch"))))
@@ -2045,6 +2055,7 @@ the boot loader configuration.")
(list
#:configure-flags
#~(list
+ "--with-curl"
"--enable-documentation=no" ;; FIXME
"--enable-system-helper=no"
"--localstatedir=/var"
@@ -2108,19 +2119,22 @@ cp -r /tmp/locale/*/en_US.*")))
bubblewrap
curl
dconf
- fuse-2
+ fuse
gdk-pixbuf
gpgme
json-glib
libarchive
+ libcap
libostree
libseccomp
libsoup-minimal-2
libxau
libxml2
p11-kit
+ polkit
util-linux
- xdg-dbus-proxy))
+ xdg-dbus-proxy
+ zstd))
(propagated-inputs (list glib-networking gnupg gsettings-desktop-schemas))
(home-page "https://flatpak.org")
(synopsis "System for building, distributing, and running sandboxed desktop