summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 8291740998..c608f397dc 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -219,9 +219,9 @@ the Nix package manager.")
;;
;; Note: use a very short commit id; with a longer one, the limit on
;; hash-bang lines would be exceeded while running the tests.
- (let ((commit "d9da3a757d3081403081577c4e07763c9b809043"))
+ (let ((commit "1162418ee88f155f6b14fd8926479c2176e40e76"))
(package (inherit guix-0.12.0)
- (version (string-append "0.12.0-4." (string-take commit 4)))
+ (version (string-append "0.12.0-5." (string-take commit 4)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -231,7 +231,7 @@ the Nix package manager.")
(commit commit)))
(sha256
(base32
- "17w9jdzm3lvfbchx7qrlkczp2jsfsi6v8cpfqh290cip5gxgz9bn"))
+ "16pxqbywhayazdgg9l19frigncmyq20j5fvaq4zgvm0iidndhfja"))
(file-name (string-append "guix-" version "-checkout"))))
(arguments
(substitute-keyword-arguments (package-arguments guix-0.12.0)
@@ -445,13 +445,13 @@ transactions from C or Python.")
(define-public diffoscope
(package
(name "diffoscope")
- (version "63")
+ (version "77")
(source (origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "12q5d2nszql1g4jf2ss863v0wpvvhrkaivqzhy6af9m9zwvw0p0k"))))
+ "0wrb6pl88611frxj19kq3vikhbld40fy1ncrskb1iayxsmbfcbn9"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -464,12 +464,7 @@ transactions from C or Python.")
(("'python-magic',") ""))))
(add-after 'unpack 'embed-tool-references
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "diffoscope/difference.py"
- (("@tool_required\\('colordiff'\\)") "")
- (("\\[\"colordiff\"")
- (string-append "[\"" (which "colordiff") "\"")))
- (substitute* "diffoscope/comparators/utils.py"
- (("@tool_required\\('xxd'\\)") "")
+ (substitute* "diffoscope/comparators/utils/compare.py"
(("\\['xxd',")
(string-append "['" (which "xxd") "',")))
(substitute* "diffoscope/comparators/elf.py"