summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm31
1 files changed, 6 insertions, 25 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 408734d6fa..62c6b488a6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -118,42 +118,23 @@ the Nix package manager.")
(define guix-devel
;; Development version of Guix.
- (let ((commit "3b09332"))
+ (let ((commit "4655005"))
(package (inherit guix-0.8)
(version (string-append "0.8." commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "git://git.sv.gnu.org/guix.git")
- (commit commit)
- (recursive? #t)))
+ (commit commit)))
(sha256
(base32
- "1szlyhpy688ca96kfyjb6cdy5zhxvqmdig4m7ql7rjqfmz0gvka1"))))
+ "04dmmnr88mwpsl0mmv03hpllyinn9cs4mmly8k0jm2acwnsni3ii"))))
(arguments
(substitute-keyword-arguments (package-arguments guix-0.8)
((#:phases phases)
`(alist-cons-before
'configure 'bootstrap
(lambda _
- ;; Comment out `git' invocations, since 'git-fetch' provides us
- ;; with a checkout that includes sub-modules.
- (substitute* "bootstrap"
- (("git ")
- "true git "))
-
- ;; Keep a list of the files already available under nix/...
- (call-with-output-file "ls-R"
- (lambda (port)
- (for-each (lambda (file)
- (format port "~a~%" file))
- (find-files "nix" ""))))
-
- ;; ... and use that as a substitute to 'git ls-tree'.
- (substitute* "nix/sync-with-upstream"
- (("git ls-tree HEAD -- [[:graph:]]+")
- "cat ls-R"))
-
;; Make sure 'msgmerge' can modify the PO files.
(for-each (lambda (po)
(chmod po #o666))
@@ -177,14 +158,14 @@ the Nix package manager.")
(define-public nix
(package
(name "nix")
- (version "1.7")
+ (version "1.8")
(source (origin
(method url-fetch)
(uri (string-append "http://nixos.org/releases/nix/nix-"
version "/nix-" version ".tar.xz"))
(sha256
(base32
- "14nc7mnma5sffqk9mglbf99w3jm4ck8pxnmkgyhy3qra9xjn749l"))))
+ "077hircacgi9y4n6kf48qp4laz1h3ab6sif3rcci1jy13f05w2m3"))))
(build-system gnu-build-system)
;; XXX: Should we pass '--with-store-dir=/gnu/store'? But then we'd also
;; need '--localstatedir=/var'. But then! The thing would use /var/nix