summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b437599db5..591f60307e 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -247,7 +247,7 @@ the Nix package manager.")
(native-inputs
`(("autoconf" ,(autoconf-wrapper))
("automake" ,automake)
- ("gettext" ,gnu-gettext)
+ ("gettext" ,gettext-minimal)
("texinfo" ,texinfo)
("graphviz" ,graphviz)
("help2man" ,help2man)
@@ -493,6 +493,13 @@ transactions from C or Python.")
(lambda _
(substitute* "setup.py"
(("'python-magic',") ""))))
+ ;; The test suite assumes we have pytest >= 2.9.0.
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=841146
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "tests/comparators/utils.py"
+ (("skip\\(reason\\=\\\"requires \\{\\}\\\"\\.format\\(tool\\)\\)")
+ "skipif(True, reason=\"Requires pytest >= 2.9\")"))))
(add-before 'build 'disable-egg-zipping
(lambda _
;; Leave the .egg file uncompressed.