summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ao-cad-aarch64-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ao-cad-aarch64-support.patch')
-rw-r--r--gnu/packages/patches/ao-cad-aarch64-support.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/ao-cad-aarch64-support.patch b/gnu/packages/patches/ao-cad-aarch64-support.patch
new file mode 100644
index 0000000000..291369cd9b
--- /dev/null
+++ b/gnu/packages/patches/ao-cad-aarch64-support.patch
@@ -0,0 +1,18 @@
+Support in ao-cad for aarch64.
+
+Submitted upstream at https://github.com/mkeeter/ao/issues/69
+
+--- ao/ui/vendor/efsw/src/efsw/inotify-nosys.h.orig 2017-12-14 16:27:16.125871099 -0600
++++ ao/ui/vendor/efsw/src/efsw/inotify-nosys.h 2017-12-14 16:26:39.786022981 -0600
+@@ -69,6 +69,11 @@
+ # define __NR_inotify_add_watch (__NR_SYSCALL_BASE+317)
+ # define __NR_inotify_rm_watch (__NR_SYSCALL_BASE+318)
+
++#elif defined (__aarch64__)
++# define __NR_inotify_init 1043
++# define __NR_inotify_add_watch 27
++# define __NR_inotify_rm_watch 28
++
+ #elif defined (__frv__)
+ # define __NR_inotify_init 291
+ # define __NR_inotify_add_watch 292