summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ceph-fix-snappy-breaking-change.patch')
-rw-r--r--gnu/packages/patches/ceph-fix-snappy-breaking-change.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch b/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
new file mode 100644
index 0000000000..7a10e2e4ae
--- /dev/null
+++ b/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
@@ -0,0 +1,13 @@
+Patch tracked upstream at https://tracker.ceph.com/issues/50934
+
+--- a/src/compressor/snappy/SnappyCompressor.h
++++ b/src/compressor/snappy/SnappyCompressor.h
+@@ -96,7 +96,7 @@ class SnappyCompressor : public Compressor {
+ if (qat_enabled)
+ return qat_accel.decompress(p, compressed_len, dst);
+ #endif
+- snappy::uint32 res_len = 0;
++ uint32_t res_len = 0;
+ BufferlistSource source_1(p, compressed_len);
+ if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
+ return -1;