summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/curl-easy-lock.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/curl-easy-lock.patch')
-rw-r--r--gnu/packages/patches/curl-easy-lock.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/curl-easy-lock.patch b/gnu/packages/patches/curl-easy-lock.patch
new file mode 100644
index 0000000000..137106f57c
--- /dev/null
+++ b/gnu/packages/patches/curl-easy-lock.patch
@@ -0,0 +1,31 @@
+This patch is taken from upstream master, and should probably be dropped
+with the next release.
+
+ihttps://github.com/curl/curl/commit/e2e7f54b7bea521fa8373095d0f43261a720cda0.patch
+
+From e2e7f54b7bea521fa8373095d0f43261a720cda0 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Mon, 27 Jun 2022 08:46:21 +0200
+Subject: [PATCH] easy_lock.h: include sched.h if available to fix build
+
+Patched-by: Harry Sintonen
+
+Closes #9054
+---
+ lib/easy_lock.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/lib/easy_lock.h b/lib/easy_lock.h
+index 819f50ce815b8..1f54289ceb2d3 100644
+--- a/lib/easy_lock.h
++++ b/lib/easy_lock.h
+@@ -36,6 +36,9 @@
+
+ #elif defined (HAVE_ATOMIC)
+ #include <stdatomic.h>
++#if defined(HAVE_SCHED_YIELD)
++#include <sched.h>
++#endif
+
+ #define curl_simple_lock atomic_bool
+ #define CURL_SIMPLE_LOCK_INIT false