summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/elixir-path-length.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/elixir-path-length.patch')
-rw-r--r--gnu/packages/patches/elixir-path-length.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/elixir-path-length.patch b/gnu/packages/patches/elixir-path-length.patch
new file mode 100644
index 0000000000..aa8bf38829
--- /dev/null
+++ b/gnu/packages/patches/elixir-path-length.patch
@@ -0,0 +1,15 @@
+In the package definition the call to the command 'git' is substituted with
+the full path to the git executable. This change causes the mix formatting tool
+to complain that the line is too long. This workaround reformats the file
+after the substitution is made.
+
+--- a/Makefile
++++ b/Makefile
+@@ -213,6 +213,7 @@
+ TEST_ERLS = $(addprefix $(TEST_EBIN)/, $(addsuffix .beam, $(basename $(notdir $(wildcard $(TEST_ERL)/*.erl)))))
+
+ test_formatted: compile
++ bin/elixir bin/mix format lib/mix/lib/mix/scm/git.ex
+ bin/elixir bin/mix format --check-formatted
+
+ test_erlang: compile $(TEST_ERLS)