summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-telega-path-placeholder.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/emacs-telega-path-placeholder.patch')
-rw-r--r--gnu/packages/patches/emacs-telega-path-placeholder.patch41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/patches/emacs-telega-path-placeholder.patch b/gnu/packages/patches/emacs-telega-path-placeholder.patch
index 5829edd22a..07ab8c1e66 100644
--- a/gnu/packages/patches/emacs-telega-path-placeholder.patch
+++ b/gnu/packages/patches/emacs-telega-path-placeholder.patch
@@ -1,18 +1,31 @@
-From bf95de21faa623e48bca00d6a2c9b33ab2c5d812 Mon Sep 17 00:00:00 2001
+From bfcd616f2870c8c3ffc9a526fcd574eb5e726a96 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
-Date: Wed, 8 Dec 2021 11:01:31 +0300
-Subject: [PATCH] Use absolute path for telega-server-command.
+Date: Sat, 14 Jan 2023 09:33:34 +0400
+Subject: [PATCH] Add path placeholder for telega-server-command and etc-file.
---
+ telega-core.el | 2 +-
telega-customize.el | 2 +-
- telega-util.el | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
+diff --git a/telega-core.el b/telega-core.el
+index 36f121e..f9f7976 100644
+--- a/telega-core.el
++++ b/telega-core.el
+@@ -41,7 +41,7 @@
+
+ (defun telega-etc-file (filename)
+ "Return absolute path to FILENAME from etc/ directory in telega."
+- (expand-file-name (concat "etc/" filename) telega--lib-directory))
++ (concat "@TELEGA_SHARE@" "/" filename))
+
+ (defconst telega-spoiler-translation-table
+ (let ((table (make-char-table 'translation-table)))
diff --git a/telega-customize.el b/telega-customize.el
-index 0af343f..cc2938c 100644
+index 0efb001..77cec5f 100644
--- a/telega-customize.el
+++ b/telega-customize.el
-@@ -591,7 +591,7 @@ In range [1..3]. Use 1."
+@@ -633,7 +633,7 @@ In range [1..3]. Use 1."
:prefix "telega-server-"
:group 'telega)
@@ -21,19 +34,5 @@ index 0af343f..cc2938c 100644
"Command to run as telega server.
It should be absolute path or binary file searchable in `exec-path'."
:type 'string
-diff --git a/telega-util.el b/telega-util.el
-index 6340c27..01e3cb7 100644
---- a/telega-util.el
-+++ b/telega-util.el
-@@ -587,7 +587,7 @@ N can't be 0."
-
- (defun telega-etc-file (filename)
- "Return absolute path to FILENAME from etc/ directory in telega."
-- (expand-file-name (concat "etc/" filename) telega--lib-directory))
-+ (concat "@TELEGA_SHARE@" "/" filename))
-
- (defun telega-link-props (link-type link-to &optional face)
- "Generate props for link button openable with `telega-link--button-action'."
--
-2.34.0
-
+2.38.1