summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ganeti-sphinx-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ganeti-sphinx-compat.patch')
-rw-r--r--gnu/packages/patches/ganeti-sphinx-compat.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/ganeti-sphinx-compat.patch b/gnu/packages/patches/ganeti-sphinx-compat.patch
new file mode 100644
index 0000000000..4e84abbf37
--- /dev/null
+++ b/gnu/packages/patches/ganeti-sphinx-compat.patch
@@ -0,0 +1,24 @@
+Adjust documentation for Sphinx 4.0.
+
+Discussed upstream at <https://github.com/ganeti/ganeti/pull/1615>.
+
+diff --git a/doc/index.rst b/doc/index.rst
+--- a/doc/index.rst
++++ b/doc/index.rst
+@@ -119,7 +119,6 @@ Draft designs
+ design-hotplug.rst
+ design-internal-shutdown.rst
+ design-kvmd.rst
+- design-location.rst
+ design-linuxha.rst
+ design-location.rst
+ design-lu-generated-jobs.rst
+diff --git a/lib/build/shell_example_lexer.py b/lib/build/shell_example_lexer.py
+--- a/lib/build/shell_example_lexer.py
++++ b/lib/build/shell_example_lexer.py
+@@ -79,4 +79,4 @@ class ShellExampleLexer(RegexLexer):
+
+
+ def setup(app):
+- app.add_lexer("shell-example", ShellExampleLexer())
++ app.add_lexer("shell-example", ShellExampleLexer)