summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghostscript-CVE-2016-7978.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ghostscript-CVE-2016-7978.patch')
-rw-r--r--gnu/packages/patches/ghostscript-CVE-2016-7978.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/ghostscript-CVE-2016-7978.patch b/gnu/packages/patches/ghostscript-CVE-2016-7978.patch
new file mode 100644
index 0000000000..81cb26e9ed
--- /dev/null
+++ b/gnu/packages/patches/ghostscript-CVE-2016-7978.patch
@@ -0,0 +1,25 @@
+From 6f749c0c44e7b9e09737b9f29edf29925a34f0cf Mon Sep 17 00:00:00 2001
+From: Chris Liddell <chris.liddell@artifex.com>
+Date: Wed, 5 Oct 2016 09:59:25 +0100
+Subject: [PATCH] Bug 697179: Reference count device icc profile
+
+when copying a device
+---
+ base/gsdevice.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/base/gsdevice.c b/base/gsdevice.c
+index 778106f..aea986a 100644
+--- a/base/gsdevice.c
++++ b/base/gsdevice.c
+@@ -614,6 +614,7 @@ gx_device_init(gx_device * dev, const gx_device * proto, gs_memory_t * mem,
+ dev->memory = mem;
+ dev->retained = !internal;
+ rc_init(dev, mem, (internal ? 0 : 1));
++ rc_increment(dev->icc_struct);
+ }
+
+ void
+--
+2.9.1
+