summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnunet-fix-scheduler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/gnunet-fix-scheduler.patch')
-rw-r--r--gnu/packages/patches/gnunet-fix-scheduler.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnunet-fix-scheduler.patch b/gnu/packages/patches/gnunet-fix-scheduler.patch
new file mode 100644
index 0000000000..1e0aef2a1a
--- /dev/null
+++ b/gnu/packages/patches/gnunet-fix-scheduler.patch
@@ -0,0 +1,13 @@
+Index: src/util/scheduler.c
+===================================================================
+--- src/util/scheduler.c (revision 31745)
++++ src/util/scheduler.c (working copy)
+@@ -1599,7 +1599,7 @@
+ int real_fd;
+
+ GNUNET_DISK_internal_file_handle_ (fd, &real_fd, sizeof (int));
+- GNUNET_assert (real_fd > 0);
++ GNUNET_assert (real_fd >= 0);
+ return add_without_sets (
+ delay, priority,
+ on_read ? real_fd : -1,