summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-ssh-double-free.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/guile-ssh-double-free.patch')
-rw-r--r--gnu/packages/patches/guile-ssh-double-free.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-ssh-double-free.patch b/gnu/packages/patches/guile-ssh-double-free.patch
new file mode 100644
index 0000000000..9692b81d39
--- /dev/null
+++ b/gnu/packages/patches/guile-ssh-double-free.patch
@@ -0,0 +1,37 @@
+Fix a double-free or use-after-free issue with Guile-SSH used
+with Guile 2.2. See <https://bugs.gnu.org/26976>.
+
+diff --git a/libguile-ssh/channel-type.c b/libguile-ssh/channel-type.c
+index 3dd641f..0839854 100644
+--- a/libguile-ssh/channel-type.c
++++ b/libguile-ssh/channel-type.c
+@@ -229,10 +229,11 @@ ptob_close (SCM channel)
+ ssh_channel_free (ch->ssh_channel);
+ }
+
++ SCM_SETSTREAM (channel, NULL);
++
+ #if USING_GUILE_BEFORE_2_2
+ scm_gc_free (pt->write_buf, pt->write_buf_size, "port write buffer");
+ scm_gc_free (pt->read_buf, pt->read_buf_size, "port read buffer");
+- SCM_SETSTREAM (channel, NULL);
+
+ return 0;
+ #endif
+diff --git a/libguile-ssh/sftp-file-type.c b/libguile-ssh/sftp-file-type.c
+index 8879924..f87cf03 100644
+--- a/libguile-ssh/sftp-file-type.c
++++ b/libguile-ssh/sftp-file-type.c
+@@ -224,10 +224,11 @@ ptob_close (SCM sftp_file)
+ sftp_close (fd->file);
+ }
+
++ SCM_SETSTREAM (sftp_file, NULL);
++
+ #if USING_GUILE_BEFORE_2_2
+ scm_gc_free (pt->write_buf, pt->write_buf_size, "port write buffer");
+ scm_gc_free (pt->read_buf, pt->read_buf_size, "port read buffer");
+- SCM_SETSTREAM (sftp_file, NULL);
+
+ return 1;
+ #endif