summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch b/gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch
new file mode 100644
index 0000000000..261d3e0e2c
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch
@@ -0,0 +1,29 @@
+From bfad3fb6fc3ab05819be144567ad99921c0c87be Mon Sep 17 00:00:00 2001
+From: Andrea Marchesini <amarchesini@mozilla.com>
+Date: Thu, 4 Jun 2015 15:04:09 +0100
+Subject: [PATCH] Bug 1169867 - nsXMLHttpRequest should use and free mProxy
+ correctly. r=ehsan, a=abillings
+
+--HG--
+extra : transplant_source : 7%D0%8A%F8G%3E%E3%D5%07%5B%7F%D4%2Ct%A6v%CCk%A1%F5
+---
+ dom/workers/XMLHttpRequest.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dom/workers/XMLHttpRequest.cpp b/dom/workers/XMLHttpRequest.cpp
+index bf0cd3f..5690af5 100644
+--- a/dom/workers/XMLHttpRequest.cpp
++++ b/dom/workers/XMLHttpRequest.cpp
+@@ -1891,8 +1891,8 @@ XMLHttpRequest::Open(const nsACString& aMethod, const nsAString& aUrl,
+
+ mProxy->mOpening = true;
+ if (!runnable->Dispatch(mWorkerPrivate->GetJSContext())) {
+- ReleaseProxy();
+ mProxy->mOpening = false;
++ ReleaseProxy();
+ aRv.Throw(NS_ERROR_FAILURE);
+ return;
+ }
+--
+2.4.3
+