summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-CVE-2015-7196.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-7196.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-7196.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-7196.patch b/gnu/packages/patches/icecat-CVE-2015-7196.patch
new file mode 100644
index 0000000000..6114ebf505
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-7196.patch
@@ -0,0 +1,27 @@
+From 3ed5c713015536b49dc88d3d4a36b60833ccd09a Mon Sep 17 00:00:00 2001
+From: Jan de Mooij <jdemooij@mozilla.com>
+Date: Tue, 25 Aug 2015 13:11:41 +0200
+Subject: [PATCH] Bug 1140616 - Crash when _releaseobject is called on the
+ wrong thread. r=bsmedberg, a=sledru, a=lizzard
+
+--HG--
+extra : source : 6a513309283d06f56cebee8528cfcf134a74f3c4
+---
+ dom/plugins/base/nsNPAPIPlugin.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/dom/plugins/base/nsNPAPIPlugin.cpp b/dom/plugins/base/nsNPAPIPlugin.cpp
+index f0d07fa..9cd2e05 100644
+--- a/dom/plugins/base/nsNPAPIPlugin.cpp
++++ b/dom/plugins/base/nsNPAPIPlugin.cpp
+@@ -1413,6 +1413,7 @@ _releaseobject(NPObject* npobj)
+ {
+ if (!NS_IsMainThread()) {
+ NPN_PLUGIN_LOG(PLUGIN_LOG_ALWAYS,("NPN_releaseobject called from the wrong thread\n"));
++ MOZ_CRASH("NPN_releaseobject called from the wrong thread");
+ }
+ if (!npobj)
+ return;
+--
+2.5.0
+