summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kiki-level-selection-crash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/kiki-level-selection-crash.patch')
-rw-r--r--gnu/packages/patches/kiki-level-selection-crash.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/kiki-level-selection-crash.patch b/gnu/packages/patches/kiki-level-selection-crash.patch
new file mode 100644
index 0000000000..8cc6478509
--- /dev/null
+++ b/gnu/packages/patches/kiki-level-selection-crash.patch
@@ -0,0 +1,19 @@
+Downloaded from https://anonscm.debian.org/viewvc/pkg-games/packages/trunk/kiki-the-nano-bot/debian/patches/level-selection-with-no-levels-solved.patch?revision=8291&view=co
+
+Kiki crashes if the user tries to use the level selection menu before
+finishing any level.
+
+Peter De Wachter (pdewacht@gmail.com)
+placed in the public domain
+
+--- a/py/levelselection.py
++++ b/py/levelselection.py
+@@ -25,6 +25,8 @@
+ # ............................................................................................................
+
+ last_level = highscore.getLastAvailableLevel()
++ if last_level < 0:
++ last_level = 0
+ current_level = (level_index >= 0) and level_index or last_level
+
+ world.max_level_index = last_level