summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kodi-increase-test-timeout.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/kodi-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/kodi-increase-test-timeout.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/kodi-increase-test-timeout.patch b/gnu/packages/patches/kodi-increase-test-timeout.patch
deleted file mode 100644
index 8fb149ff9d..0000000000
--- a/gnu/packages/patches/kodi-increase-test-timeout.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Increase thread timeout to reduce flakiness.
-
-Taken from upstream:
-https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
-
-diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
-index 42fb8c2fc609..40e644c0ed3c 100644
---- a/xbmc/threads/test/TestEvent.cpp
-+++ b/xbmc/threads/test/TestEvent.cpp
-@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
- EXPECT_TRUE(w3.result == NULL);
-
- // this should end given the wait is for only 50 millis
-- EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
-+ EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
-
- EXPECT_TRUE(!w3.waiting);
- EXPECT_TRUE(w3.result == NULL);