summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/linux-libre-mips-math-emu-fix-pt1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/linux-libre-mips-math-emu-fix-pt1.patch')
-rw-r--r--gnu/packages/patches/linux-libre-mips-math-emu-fix-pt1.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/linux-libre-mips-math-emu-fix-pt1.patch b/gnu/packages/patches/linux-libre-mips-math-emu-fix-pt1.patch
new file mode 100644
index 0000000000..bd7cb7281e
--- /dev/null
+++ b/gnu/packages/patches/linux-libre-mips-math-emu-fix-pt1.patch
@@ -0,0 +1,35 @@
+From 58f2873fbfd3b6734e4affedfcba569e3369f646 Mon Sep 17 00:00:00 2001
+From: Mark H Weaver <mhw@netris.org>
+Date: Thu, 6 Aug 2015 01:22:42 -0400
+Subject: [PATCH 1/9] Don't process empty cause flags after simple fp move on
+ MIPS.
+
+---
+ arch/mips/math-emu/cp1emu.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
+index 22b9b2c..139af11 100644
+--- a/arch/mips/math-emu/cp1emu.c
++++ b/arch/mips/math-emu/cp1emu.c
+@@ -1746,7 +1746,7 @@ static int fpu_emu(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
+ case fmov_op:
+ /* an easy one */
+ SPFROMREG(rv.s, MIPSInst_FS(ir));
+- goto copcsr;
++ break;
+
+ /* binary op on handler */
+ scopbop:
+@@ -1943,7 +1943,7 @@ copcsr:
+ case fmov_op:
+ /* an easy one */
+ DPFROMREG(rv.d, MIPSInst_FS(ir));
+- goto copcsr;
++ break;
+
+ /* binary op on handler */
+ dcopbop:
+--
+2.4.3
+