summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mariadb-cmake-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mariadb-cmake-compat.patch')
-rw-r--r--gnu/packages/patches/mariadb-cmake-compat.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/mariadb-cmake-compat.patch b/gnu/packages/patches/mariadb-cmake-compat.patch
new file mode 100644
index 0000000000..44b0daa186
--- /dev/null
+++ b/gnu/packages/patches/mariadb-cmake-compat.patch
@@ -0,0 +1,17 @@
+Fix if statement that triggers syntax error in CMake 3.20 and later.
+
+Taken from upstream:
+https://github.com/mariadb-corporation/mariadb-connector-c/commit/242cab8c
+
+diff --git a/libmariadb/cmake/ConnectorName.cmake b/libmariadb/cmake/ConnectorName.cmake
+--- a/libmariadb/cmake/ConnectorName.cmake
++++ b/libmariadb/cmake/ConnectorName.cmake
+@@ -22,7 +22,7 @@ IF(CMAKE_SYSTEM_NAME MATCHES "Windows")
+ SET(MACHINE_NAME "x64")
+ ELSE()
+ SET(MACHINE_NAME "32")
+- END()
++ ENDIF()
+ ENDIF()
+
+ SET(product_name "mysql-connector-c-${CPACK_PACKAGE_VERSION}-${PLATFORM_NAME}${CONCAT_SIGN}${MACHINE_NAME}") \ No newline at end of file