summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/nautilus-disable-tracker-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/nautilus-disable-tracker-tests.patch')
-rw-r--r--gnu/packages/patches/nautilus-disable-tracker-tests.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/patches/nautilus-disable-tracker-tests.patch b/gnu/packages/patches/nautilus-disable-tracker-tests.patch
new file mode 100644
index 0000000000..bcc7b38f33
--- /dev/null
+++ b/gnu/packages/patches/nautilus-disable-tracker-tests.patch
@@ -0,0 +1,47 @@
+The tracker test hangs in the build container (see:
+https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
+
+--- a/test/automated/displayless/meson.build 2022-09-10 00:52:50.348405729 -0400
++++ b/test/automated/displayless/meson.build 2022-09-10 00:53:07.267907525 -0400
+@@ -34,41 +34,3 @@
+ 'test-file-operations-trash-or-delete.c'
+ ]]
+ ]
+-
+-tracker_tests = [
+- ['test-nautilus-search-engine-tracker', [
+- 'test-nautilus-search-engine-tracker.c',
+- ]],
+-]
+-
+-foreach t: tests
+- test(
+- t[0],
+- executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep),
+- env: [
+- test_env,
+- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+- ],
+- timeout: 480
+- )
+-endforeach
+-
+-
+-
+-# Tests that read and write from the Tracker index are run using 'tracker-sandbox'
+-# script to use a temporary instance of tracker-miner-fs instead of the session one.
+-foreach t: tracker_tests
+- test_exe = executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep)
+- test(
+- t[0],
+- tracker_sandbox,
+- args: ['--store-tmpdir', '--index-recursive-tmpdir', test_exe],
+- env: [
+- test_env,
+- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+- ],
+- timeout: 480
+- )
+-endforeach