summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/onnx-shared-libraries.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/onnx-shared-libraries.patch')
-rw-r--r--gnu/packages/patches/onnx-shared-libraries.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/onnx-shared-libraries.patch b/gnu/packages/patches/onnx-shared-libraries.patch
new file mode 100644
index 0000000000..00583b35da
--- /dev/null
+++ b/gnu/packages/patches/onnx-shared-libraries.patch
@@ -0,0 +1,24 @@
+These linker options for the 'onnx_cpp2py_export.cpython-38-*-gnu.so'
+(or similar) extension are meant to be used when building 'libonn.a',
+a static archive. This patch adapts the link flags to linking with
+'libonnx.so'.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cede3073..52f846ed 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -475,11 +475,10 @@ if(BUILD_ONNX_PYTHON)
+ PRIVATE $<TARGET_OBJECTS:onnx>)
+ else()
+ # Assume everything else is like gcc
+- target_link_libraries(onnx_cpp2py_export
+- PRIVATE "-Wl,--whole-archive" $<TARGET_FILE:onnx>
+- "-Wl,--no-whole-archive")
++ target_link_libraries(onnx_cpp2py_export PRIVATE onnx)
+ set_target_properties(onnx_cpp2py_export
+- PROPERTIES LINK_FLAGS "-Wl,--exclude-libs,ALL")
++ PROPERTIES LINK_FLAGS
++ "-Wl,-rpath=${CMAKE_INSTALL_PREFIX}/lib")
+ endif()
+
+ target_link_libraries(onnx_cpp2py_export PRIVATE onnx)