summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch')
-rw-r--r--gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch b/gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch
deleted file mode 100644
index c25c3bd7a9..0000000000
--- a/gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From cef2c8df44166195e1705638f9f17033a4943bb7 Mon Sep 17 00:00:00 2001
-From: Simon Cross <hodgestar@gmail.com>
-Date: Sun, 16 Feb 2014 18:32:21 +0000
-Subject: [PATCH 02/15] Disable the speedups C extension on CPython >= 3.3
- since Genshi doesn't support the new Unicode C API yet.
-
----
- setup.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 123a2cb..a3d748c 100755
---- a/setup.py
-+++ b/setup.py
-@@ -65,9 +65,13 @@ available.""")
-
-
- if Feature:
-+ # Optional C extension module for speeding up Genshi:
-+ # Not activated by default on:
-+ # - PyPy (where it harms performance)
-+ # - CPython >= 3.3 (the new Unicode C API is not supported yet)
- speedups = Feature(
- "optional C speed-enhancements",
-- standard = not is_pypy,
-+ standard = not is_pypy and sys.version_info < (3, 3),
- ext_modules = [
- Extension('genshi._speedups', ['genshi/_speedups.c']),
- ],
---
-2.12.0
-